Forum Stats

  • 3,875,555 Users
  • 2,266,945 Discussions
  • 7,912,249 Comments

Discussions

mod: CGI Digest::MD5Error. Perl module CGI Digest::MD5 is not installed

2633645
2633645 Member Posts: 30
edited Mar 16, 2015 9:58AM in Enterprise Manager Ops Center

When installing OPS version 12.2.1.810 on Linux, in step "Install OS provisioning components" I get error

Failed Step:  Install OS provisioning components.

The following is a portion of the installer

log which may indicate the cause of the error.

If this does not indicate the cause of the

error, you will need to view the full log

  1. file. More information on how to do that is

available below.

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

mod: CGI Digest::MD5Error. Perl module CGI Digest::MD5 is not installed.

Error running /var/tmp/OC/xvmoc_full_bundle/./Linux_i686/Product/installer/proxy-jobs/7installOSPProxy.pl

Executing job: jobs/82installOSPSat.pl --install --remoteDBprops=/var/tmp/RemoteDBProps.txt

Executing job: 7installOSPProxy.pl --install

Useless use of a constant in void context at /var/tmp/OC/xvmoc_full_bundle/./Linux_i686/Product/installer/proxy-jobs/7installOSPProxy.pl line 1051.

Validating versions of tftp, dhcpd and nfs

Validating version of wget installed

Validating version of Perl installed

mod: CGI Digest::MD5Error. Perl module CGI Digest::MD5 is not installed.

Error running /var/tmp/OC/xvmoc_full_bundle/./Linux_i686/Product/installer/proxy-jobs/7installOSPProxy.pl

OS version:

uname -a

Linux XXXXXXXXX 3.8.13-44.1.1.el6uek.x86_64 #2 SMP Wed Sep 10 06:10:25 PDT 2014 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/issue

Oracle Linux Server release 6.5

Instaled perl rpm's are:

rpm -qa | grep perl

perl-XML-Parser-2.36-7.el6.x86_64

perl-Digest-SHA1-2.12-2.el6.x86_64

perl-5.10.1-136.el6.x86_64

perl-IPC-Cmd-0.56-136.el6.x86_64

perl-Module-Pluggable-3.90-136.el6.x86_64

perl-ExtUtils-MakeMaker-6.55-136.el6.x86_64

perl-DBI-1.609-4.el6.x86_64

perl-Params-Check-0.26-136.el6.x86_64

perl-URI-1.40-2.el6.noarch

perl-HTML-Tagset-3.20-4.el6.noarch

perl-devel-5.10.1-136.el6.x86_64

perl-Digest-HMAC-1.01-22.el6.noarch

perl-Module-Load-0.16-136.el6.x86_64

perl-Compress-Zlib-2.021-136.el6.x86_64

perl-Digest-SHA-5.47-136.el6.x86_64

perl-DBD-SQLite-1.27-3.el6.x86_64

perl-Test-Harness-3.17-136.el6.x86_64

perl-ExtUtils-CBuilder-0.27-136.el6.x86_64

perl-DBD-Pg-2.15.1-4.el6_3.x86_64

perl-Digest-BubbleBabble-0.01-11.el6.noarch

perl-Pod-Escapes-1.04-136.el6.x86_64

perl-Pod-Simple-3.13-136.el6.x86_64

perl-IO-Compress-Base-2.021-136.el6.x86_64

perl-IO-Compress-Zlib-2.021-136.el6.x86_64

perl-libwww-perl-5.833-2.el6.noarch

perl-DBD-MySQL-4.013-3.el6.x86_64

perl-CPAN-1.9402-136.el6.x86_64

perl-Module-Load-Conditional-0.30-136.el6.x86_64

perl-ExtUtils-ParseXS-2.2003.0-136.el6.x86_64

perl-Crypt-PasswdMD5-1.3-6.el6.noarch

perl-Locale-Maketext-Simple-0.18-136.el6.x86_64

perl-Compress-Raw-Zlib-2.021-136.el6.x86_64

perl-HTML-Parser-3.64-2.el6.x86_64

perl-libs-5.10.1-136.el6.x86_64

perl-version-0.77-136.el6.x86_64

when I ran out of ideas i manualy installed required perl module via CPAN

instmodsh

Available commands are:

l            - List all installed modules

m <module>   - Select a module

q            - Quit the program

cmd? l

Installed modules are:

Digest::MD5

Perl

Test::Simple

libintl-perl

but this had no effect on the problem

Any sugestions?

Answers

This discussion has been closed.