Forum Stats

  • 3,826,326 Users
  • 2,260,624 Discussions
  • 7,896,898 Comments

Discussions

java.lang.NoClassDefFoundError for javax.servlet.jsp.jstl.core.Config with HelloWorld portlet

2976467
2976467 Member Posts: 1
edited Jul 8, 2015 1:53PM in WebCenter Portal

I have been trying for weeks now to deploy a simple Hello World WSRP portlet on a WebLogic server and integrate it into WebCenter Portal.  The portlet is actually using Spring Portlet MVC.  It is dirt simple in that all it is supposed to do is display a jsp that has Hello World hardcoded in it.  I worked my way through many issues, including the need to run my ear file through the WSRP pre-deploy processor.  But when I go to integrate it and it runs my code, it gets to the step where it needs to render my JSP.  This is done using JSTL, so it needs the javax.servlet.jsp.jstl.core.Config class.  My stack trace is giving me a java.lang.NoClassDefFoundError.  So at first, I tried to put javax.servlet.jsp.jstl-api-1.2.1.jar in my lib directory under WEB-INF in my WAR file that is inside of my EAR file.  That did not work.  Then I discovered the fact that the JSTL library is deployed on the WebLogic server.  I can see it in the list of deployments in the WebLogic console.  So I found out I needed to add a reference to the library in my weblogic.xml file and remove the jar from my lib directory.  So I did that and I still get the same error.

From my web searches, I have not found an answer to my problem.  If I could find a way to attach files here, I would attach my ear file, a screen shot showing the deployed library on the server, and a file containing the stack trace.

Tagged:

Answers

This discussion has been closed.