Forum Stats

  • 3,840,409 Users
  • 2,262,600 Discussions
  • 7,901,269 Comments

Discussions

Endeca 3.1 - Twitter - SSL

Germán Martínez-Oracle
Germán Martínez-Oracle Member Posts: 5
edited Sep 15, 2015 5:33PM in Endeca Information Discovery

Hi everybody!

I have a problem. I'm trying to read tweets from Twitter API. Endeca is configured with SSL and when reads the tweets I get:

SEVERE: javax.net.ssl.SSLKeyException: [Security:090477]Certificate chain received from api.twitter.com - 199.59.148.20 was not trusted causing SSL handshake failure.

I have configured the same certificates that we have in other environment (where it works well), but that's not working.

Can someone tell me what are the correct certificates for this case? Or how can I resolve this problem?

Thank you!

Regards!

Message was edited by: Germán Martínez-Oracle Solved! Just add the parameter -DUseSunHttpHandler=true at setDomainEnv.sh (based on a recomendation from support)

Tagged:

Answers

  • Brett R-Oracle
    Brett R-Oracle Member Posts: 264
    edited Sep 10, 2015 8:26PM

    Are you seeing this error in Integrator (Clover) Designer, or Server?

    api.twitter.com has an intermediate CA certificate (from DigiCert) between it's certificate and the trusted Root (also from DigiCert).  It is likely that you are missing the intermediate CA.

    You will probably need to import this certificate-chain into your Java trust-store in order to access the API over HTTPS.

  • Germán Martínez-Oracle
    Germán Martínez-Oracle Member Posts: 5
    edited Sep 15, 2015 5:31PM

    Thank you Brett and sorry for the delay.

    The problem was solved. We added a parameter to the setDomainEnv.sh based on a recomendation from SR. This parameter is: -DUseSunHttpHandler=true

    Regards!

This discussion has been closed.