Forum Stats

  • 3,875,763 Users
  • 2,266,969 Discussions


Does Bug 25979661 fix same problem for ORDS_PUBLIC_USER?

DrewWeath Member Posts: 2 Red Ribbon
edited Feb 25, 2019 10:37AM in Multitenant

I am researching on how to migrate our database from a Non-CDB (12.2) to a PDB and get the APEX front end working.

It appeared to work but couldn't get the front end to work, thinking it was a listener issue.  Further research showed that I had the above bug occurring for both users.

I see that there is a work around and a patch for APEX_PUBLIC_USER ORA-00600 after migrating from a Non-CDB to a PDB.

I am also experiencing the same issue with ORDS_PUBLIC_USER.

Will this patch work for the ORDS_PUBLIC_USER as well or is it user specific?


ORA-00600: internal
error code, arguments: [kziaVrfyAcctStatInRootCbk: !user],

[], [], [], [], [], [], [], [], [], []


ORA-00600: internal
error code, arguments: [kziaVrfyAcctStatInRootCbk: !user],

[], [], [], [], [], [], [], [], [], []

This is my first post and testing the waters here.  Thanks.


  • DrewWeath
    DrewWeath Member Posts: 2 Red Ribbon
    edited Feb 25, 2019 10:37AM

    I tried the published work around:

    The bug is still being worked by the Development and the workaround is available to override this issue.

    As a workaround you can make APEX_PUBLIC_USER local user by updating user$.spare1 column in the PDB.

    sqlplus / as sysdba

    alter session set container=MANCO2;

    create table backup_user$ as select * from user$;

    update user$ set spare1=0 where name='APEX_PUBLIC_USER';


    conn / as sysdba

    shutdown abort


    I learned the hard way not to use shutdown abort in a PDB.  So yes, this did correct the error for APEX_PUBLIC_USER and did the same for ORDS_PUBLIC_USER.

    However, I'm still not getting my application to appear on the web page.

    Oracle Rest Data Services is showing:

    404 Not Found

    • The request could not be mapped to any database. Check the request URL is correct, and that URL to database mappings have been correctly configured

    Not sure if I need to change SPARE1=0 for the other APEX users, since APEX only exists in the PDB.  Again I moved a 12.2 Non-CDB to a PDB.  I didn't find anything describing what changes need to be performed on the APEX (5.1.2) side of the house for this transition running with ORDS (3.0.11) and Tomcat (7.0) for the web interface.  Any suggestions on where to look or try would be helpful.  Thanks.