Forum Stats

  • 3,751,625 Users
  • 2,250,379 Discussions
  • 7,867,489 Comments

Discussions

php: modular dependency conflict with nginx in OL8

Andrew.G
Andrew.G Member Posts: 3 Green Ribbon

OS: Oracle Linux Server release 8.4 (fresh install)

Issue: php module streams depends on nginx:1.14 module stream. Hence php can't be installed on the system with nginx:1.16 and above.

Steps to reproduce:

  1. Install (or enable) nginx:1.18 module stream: dnf module install nginx:1.18
  2. Try to install php: dnf module install php

Excepted result:

Successful php installation

Actual outcome:

php installation failed with the following error:

Modular dependency problems:
 Problem 1: module php:7.2:20190512064024:76554e01-0.x86_64 requires module(nginx:1.14), but none of the providers can be installed

[skipped]

Error: Problems in request:
broken groups or modules: php

Additional information:

Related bug was fixed in upstream - 1708589. For the time being, upstream has only minor, non-blocking issue.

Tagged:

Answers

  • andreas.dijkman
    andreas.dijkman Member Posts: 74 Bronze Badge

    As stated in the bug-note, the newer PHP-versions don't have that problem. Is installing a recent PHP-version (7.4) not a workable solution? PHP 7.2 is quite old these days.

    I can imagine that modules from 8.0 and 8.3 or newer won't mix properly and 7.2 isn't supported anymore since end 2020.

  • Andrew.G
    Andrew.G Member Posts: 3 Green Ribbon
    edited Jul 22, 2021 5:43PM

    Is installing a recent PHP-version (7.4) not a workable solution?

    Unfortunately not. This bug exists in all php module streams (all module versions affected) in OL8.

    So dnf module install php:7.4 will produce similar error:

    All matches for argument 'php:7.4' in module 'php:7.4' are not active
    Error: Problems in request:
    broken groups or modules: php:7.4
    Modular dependency problems:
    
     Problem: module php:7.4:8030020200615123046:a4870ff1-0.x86_64 requires module(nginx:1.14), but none of the providers can be installed
    


    Please note the following points:

    • even php:7.2 may be installed correctly on RHEL 8 and other RHEL-based distributions
    • according to the upstream Application Streams Life Cycle, retirement date for nginx 1.14 is May 2021
  • We are looking into it.

    andreas.dijkman
  • andreas.dijkman
    andreas.dijkman Member Posts: 74 Bronze Badge

    That is strange. Both php:7.2 and nginx:1.14 are retired as of may 2021. So possible fixes (I can imagine even in metadata) aren't ported to newer appstreams. But a supported appstream (php:7.4) shouldn't be dependent on retired appstream (nginx:1.14). Oracle has some catching up to do.

    Also if support for those packages is already dropped, I would find it more suitable that those packages would end up in archive-channel somehow, so that questions about support across appstreams and channels is eliminated. Hint, hint @Honglin Su-Oracle 😉