Forum Stats

  • 3,769,313 Users
  • 2,252,947 Discussions
  • 7,874,985 Comments

Discussions

Golden Gate Filter condition issue

User_IMO5J
User_IMO5J Member Posts: 2 Green Ribbon

Golden Gate filter condition on a new source table is checking the previous txn, where as If I use the existing table, it is properly checking the filter on the current txn, very weird situation/ something got enabled ?

example:

Source table -- TABLE_1 (newly created) fields - Field_1, FIeld_2

txn - 1 : values(A,100)

txn -2 : values (B,200)

MAp - Filter ( streq(field_1,'A'))


Ideally txn 1-> should turn out to be true and should replicat, but that is not happening instead filter condition taking previous txn but inserting current values..

Means --> for the txn 2 it is passing the filter (it shouldn't have) and inserting current txn data.


if someone faced a similar problem with filters , please let us know what we are missing on here.

Tagged:

Answers

  • OliverRu
    OliverRu Member Posts: 20 Blue Ribbon

    I have not seen this and agree that it is odd, because using the "after" image should be the default. For example, I have needed to filter on the before values in the past. To do that I've added the GETUPDATEBEFORES parameter to the extract (you may want to check if this parameter or something similar has snuck in somewhere) and then I've needed to explicitly notate that I want the before image... something like this: FILTER(@STREQ(@BEFORE(field_1),'A')). To prove your observation, you could try FILTER(@STREQ(@AFTER(field_1),'A')). If that works, then you know for sure that your filter is operating on the before image by default. Oracle support should be able to tell you why that is.