Forum Stats

  • 3,872,229 Users
  • 2,266,408 Discussions


ORA-36836 about cube dimensionality ???

664948 Member Posts: 3
edited Nov 24, 2008 5:26AM in OLAP
Hi there,

I've been trying lately to use AWM to build an OLAP cube based on some sample data I have related to phone communications. Up to now I've been able although painfuly to build four dimensions (date/time, a-number, b-number, exit cause) and a cube with measures "number of calls" and "total call duration". Currently everything seems to load correctly (dimensions and cube), however when I try to view the cube data I get the following message :

ORA-36836: The dimensionality of object OLAP.TRAFFIC is different than the view token

This doesn't make any sense to me, and I've not been able to find any explanation on the web, except for those two lines :

Cause: The dimensionality of the cube does not match the view token
Action: Check view token for unrelated hierarchies clauses

Well the remedy looks even worse than the disease, since this is even less understandable than the former.
Does anyone has a clue about what might be wrong here, or what to do to go forward ?

I'm using the free Oracle 11g on CentOS, I guess this must be the XE edition, and AWM was part of Oracle Client on Windows XP. This piece of software seems to be riddle with bugs, data not updating properly after changes, objects only partly deleted after a delete command, lots of "uncommitable" and java exceptions of all kinds... I've had several times to totally delete the whole aw and restart from scratch because AWM would not finish deleting some dimension of attribute. A real pain in the neck. Is this related to the fact that I'm using a free version and don't have access to patches ? Well I really wonder how can anyone do some serious development with this tool. Or am I missing something ?

Thanks for your help,


  • Hi Christian,

    Did you know that Oracle OLAP is only supported on Enterprise Edition of the Oracle Database?

    I'm really surprised that you have been able to get any OLAP functionality to work on any other edition.

    As far as 11g OLAP is concerned, I would recommend you use the recently released [ database patch|] along with [ release of AWM|] - but on Enterprise Edition only!

  • 664948
    664948 Member Posts: 3
    Hi Stuart,

    thank you for your quick answer. Here is the welcome message I get when connecting with SQL*Plus :

    Connected to:
    Oracle Database 11g Enterprise Edition Release - 64bit Production
    With the Partitioning, OLAP, Data Mining and Real Application Testing options

    So it looks like there is some OLAP option evaluation available, although it does seem somewhat of an alpha version.

    When you say "Enterprise Edition" do you mean I need to get a license ? If that's the case that's too bad because what I'm trying to do is to develop a small demo of an OLAP application to my fellow teammates and I was hoping Oracle would allow me out of the development hell I'm in with open source tools. However getting a license for this is simply out of the question, so this basically means I'm over with Oracle. Really too bad.

    Thanks for your help anyway,
  • Stuart Bunby-Oracle
    Stuart Bunby-Oracle Member Posts: 355
    edited Oct 14, 2008 6:16AM
    If you are working with then you really should apply the patches listed here. Without any patches, I am not surprised that you are experiencing lots of errors.

    There is no escaping the fact that if you want to implement Oracle OLAP then you would ultimately need to license the Enterprise Edition of the database and the OLAP option itself. However, if you are simply trying to build a demo then I would recommend downloading Oracle Enterprise Edition from OTN and working within the terms and conditions of the OTN License Agreement (you will have to accept these prior to downloading the software). I **believe**_ that you are able to work without a license for the purposes of evaluation, but if you have any doubts then you really should contact your Oracle account manager.

  • 664948
    664948 Member Posts: 3
    Hi again Stuart,

    in fact I realized right after posting the previous post that the welcome message did say that I'm using Enterprise Edition. My bad. From the terms of the license it seems very clear that these free downloads are precisely intended at that, i.e., developing and prototyping. However the current version of the OLAP option looks essentially unusable, so I'll try to get my hands on the patch you mention. Hope someone at my company will be able to find me a Metalink ID.

    Thanks a lot for your help !
  • Given the choice, you should go to

    Good luck,

  • chris_here
    chris_here Member Posts: 133
    Hi again Stuart and all,

    I'm back after some patching... :-) I've applied the following patches to my installation :

    On the server side patches 7375639 (Oracle Critical Patch Update October 2008) and 6992921 (OLAP B PATCH FOR
    On the client side I've upgraded to AWM

    And ... tadadam ... I still have the same error message after recreating the whole workspace from scratch :-(

    Here is a transcript of the error message I get :

    [edit many similar lines]

    oracle.dss.dataSource.common.OLAPException: BIB-9009 Oracle OLAP could not create cursor. java.sql.SQLException: ORA-36836: The dimensionality of object OLAP.TRAFFIC is different than the view token
    ORA-06512: at line 1 java.sql.SQLException: ORA-36836: The dimensionality of object OLAP.TRAFFIC is different than the view token
    ORA-06512: at line 1

    at oracle.dss.dataSource.common.QueryDataDirector.addDataDirectorListener(
    at oracle.dss.dataView.ModelAdapter.setDataDirector(
    at oracle.dss.crosstab.CrosstabModelAdapter.setDataSource(
    at oracle.dss.dataView.Dataview.setDataSource(
    at oracle.olap.awm.dataobject.dialog.olapi.UBiBeanUtil.getCrosstab(Unknown Source)
    at oracle.olap.awm.dataobject.dialog.olapi.UBiBeanUtil.showCrosstab(Unknown Source)
    at oracle.olap.awm.dataobject.dialog.olapi.UBiBeanUtil.showData(Unknown Source)

    [edit many similar lines]

    I'm able to display the dimension views and the cube view and they "look" ok, but I get this error when I right-click to "View data <MY CUBE>..." or "View data <ONE OF THE MEASURES>..."

    So it looks like there's something in the way my data is wrapped up that really bothers the Oracle OLAP engine. What I'm trying to do is to migrate a cube that works on Mondrian to Oracle OLAP, so it means the problem is probably related to some specific requirement that the Oracle OLAP engine imposes on the way the data is presented.

    In any case the error messages are totally meaningless to me. Does anyone has an idea what the "view token" is ?

    Thanks a lot for your help,
  • David Greenfield-Oracle
    David Greenfield-Oracle Member Posts: 877 Employee
    You will probably need to file an SR to get this resolved. In the meantime I have two questions.

    (1) Can you access the cube data via the generated views? The 'View Data' option in AWM goes through a related, but different code path, so knowing if both fail or only one should help us isolate the problem.

    (2) Are you running the data viewer as the owner of the cube? If not, then it is possible that this is a permissions issue.
  • chris_here
    chris_here Member Posts: 133
    Hi David,

    this is really the strangest part: everything seems to work perfectly ok when I create the cube, the loading of data (Maintain cube...) goes smoothy, I can view the dimensions data and also the cube data through the generated view Cubes -> TRAFFIC -> Views -> TRAFFIC_VIEW. The data looks fine, it's a simple fact table with PK (A_NUMBER, B_NUMBER, CAUSES, DATE_TIME) -> CALLS. I only get the error message when I right click on "View data TRAFFIC...". Right-clicking on "View data A_NUMBER" for instance works.

    Here is the worst part: after quite a large number of attempts using the simplest possible cube model and all or only part of the 4 dimensions, I'm able sometimes to see and navigate the cube data, i.e., not having the error message. I'm totally incapable of saying why some particular attempt will work though. All I have been able to figure out up to now is that once I get the error message I'm going to be stuck with it for quite some times, I mean I will get it even after deleting the cubes, disconnecting awm, even restarting the whole database system. Then after carefully creating some cubes, trying to modify as little options as possible... suddently I'm able to view and navigate the cube data (although with a very simple cube with no hierarchies). So currently as I'm typing this I'm able to navigate several of my cubes, but I don't dare to touch anything for fear of encountering the dreaded red arrow again :-)

    Also to answer your second question, since the error is intermittent this obvisouly isn't be related to permissions. All the work with AWM is done using a dedicated OLAP user.

    I'm ok to fill a Support Request or bug description, however since I've never done that it would be nice if you could put me on the way about how to do it.

    Also I'm going to not touch AWM anymore for a little while now that I have one working cube in order to be able to use the subsequent tools. I'm pretty confident from my earlier attempts that as soon as I will request my original cube data again the error message will come back to stay, even for the cubes that now work. This behaviour should help to determine what causes the error.

    Thanks for your help,
  • chris_here
    chris_here Member Posts: 133
    edited Nov 17, 2008 10:55AM
    Hi there again,

    does nobody have any more advice regarding this issue ? What I've tried lately is to install a whole fresh new instance of Oracle 11g then apply the OALP & Oct08 CPU patches before doing anything. I still have this bug when I try to use in a cube a dimension that has at least one hiererchy it seems. However sometimes, seemingly depending on the alignement of the stars, I'm able to get the cube completed and view the data. I don't have the slightest clue about what might cause the pb and why it sometimes works. Am I really the only one to get this error ? I find it hard to believe, as the steps to reproduce are really simple:

    1 . Install Oracle 11g Enterprise Edition on Linux (in fact CentOS 5)
    2. Apply any patch you like or none, doesn't seem to make the slighest difference
    3. Create a dimension with a hierarchy
    4. Create a cube based on that dimension, load it, watch the views, everything's ok
    5. Ask for "View cube data..." and you're stuck with "Cube dimensionality blah blah blah".

    Then I get error messages in the Oracle logs like "Internal error (ORA-600[kglrls-bad-lock]) detected in log.xml"

    This is driving me crazy. Unfortunately I'm currently not able to post a SR because the ID my company gave me doesn't seem to allow it, and all this internal stuff is very heavy to make move. Does anyone has any clue about what to do from here ?

    Please help if you can, this is really making me waste a lot of time while I should really be preparing this demo instead.

    Again any help will be greatly appreciated,
  • Hi there,

    Were you able to verify whether the error occurs with the database patch applied?

This discussion has been closed.