Forum Stats

  • 3,855,617 Users
  • 2,264,534 Discussions
  • 7,906,110 Comments

Discussions

HTTP 403 (Forbidden) with HFM 9.2

.Iain.
.Iain. Member Posts: 15 Blue Ribbon
edited Nov 6, 2008 12:54PM in Financial Consolidation
Hi,

Can anyone point int the right direction to what might be wrong? With HFM 9.2 I am getting HTTP 403 (Forbidden) message "You are not authorized to view this page" when using the default URL http://<Server Name>/HFM with version 9.2. I have also tried to connect to me app through the workspace and get "The page can not be found" error. I'm thinking it's something to do it IIS but am at a loss on how to find the issue. I'm using the Admin account on the server which was used for all the installations (both OS Win 2003 & HFM).

Thanks for any insight you can provide.....

Iain
Tagged:

Answers

  • 608768
    608768 Member Posts: 114
    Did you follow the DCOM set-up in the installation? What version of IIS is that installed correctly?
  • .Iain.
    .Iain. Member Posts: 15 Blue Ribbon
    Do I need DCOM setup if I'm using the Administrator account? If I do have you got a guide I can follow or point me where I can obtain one? IIS is version V6.0
  • Antonio R.
    Antonio R. Member Posts: 510 Silver Badge
    You can also check in your services whether ISS is running or not, if it is, go to the IIS Manager under your administrative tools and under the Websites folders, expand the Default Web Site, in there you should find the HFM application where the icon looks like a Gear, right click on it and select browse, fir everything is ok you should get the word hfm on the right hand side of the screen.
    This should point you in the right direction, otherwise, at the command line type dcomcnfg to check the DCOM configuration as previously suggested.
  • .Iain.
    .Iain. Member Posts: 15 Blue Ribbon
    IIS is running, browsing from the HFM gear produces the same 403 (forbidden) error screen. Checked the DCOM settings for all the HFM related components, Identity tab has the Admin account, checked the Security tab for Launch and Activation, Access Permissions & Configuration Permissions and Admin account, ANONYMOUS LOGON and Everyone has all the available permissions.....
  • Antonio R.
    Antonio R. Member Posts: 510 Silver Badge
    Compare my settings below to yours for trouble shooting purposes:
    Right Click on the HFM Folder in IIS on your default Website, select properties; compare this:
    Local Path on the Virtual Directory Tab: = C:\Hyperion\FinancialManagement\Web\HFM
    Read Box Checked
    Application Name = HFM
    Execute Permissions= Scripts only
    Application Pool = DefaultAppPool
    Directory Security Tab :
    EnableAnonymousAccess = Checked
    UserName=IUSR_MyServer
    No IP Address set as restricted
    Secure Communications is not enabled
    ASP.Net Tab:
    version: 1.1.4322
    Virtual Path/HFM
    File Location: C:\Hyperion\FinancialManagement\Web\HFM\web.config

    Also, check your WebService Extensions to make sure the Active Server Pages ASP.Net are "Allowed"

    Hope this help.

    Raul Rodriguez
  • .Iain.
    .Iain. Member Posts: 15 Blue Ribbon
    edited Nov 5, 2008 4:23PM
    Thanks for your help!

    All my settings are the same as you have listed......

    Edited by: user7322684 on Nov 5, 2008 1:23 PM
  • Antonio R.
    Antonio R. Member Posts: 510 Silver Badge
    Try redeploying your Webserver, but this time, do not select IIS, use the apache, and re-register your HFM application.
This discussion has been closed.