Forum Stats

  • 3,854,961 Users
  • 2,264,441 Discussions
  • 7,905,847 Comments

Discussions

Import Wizard

698124
698124 Member Posts: 5
edited Dec 18, 2009 3:42AM in SQL Developer
I am trying to load data into a table using the SQL Developer import wizard. The data is a single column of containing just over 4000 cells of an 11 digit number formatted as text (because of leading zeros).
- I have attempted to import the file as a flat txt file, hich does not work becuase oracle doesnt have a txt reader.
- Then i imported the data into excel and tried that, it does not get passed the preview window. I started SQL Developer with the logging window open and saw the following message "You cannot get a numeric value from a string based cell". I have the column in my table formatted as varchar and as char, so i don't know why it is trying to pull a numeric value when i want the numbers treated as text.
- Then after reading some forums i tried converting the excel file to a csv file (loosing my leading zeros) and importing the csv file into my new table. I keep getting the error "Source columns 'Column0' , do not have data types assigned".

Any suggestions....

Thanks!

FYI using SQLDeveloper 1.5.1 Build 54.40

Answers

  • -K-
    -K- Member Posts: 6,171
    Because of the many fixes, it's worth a try on the current 2.1 release...

    Hope that helps,
    K.
    -K-
  • 698124
    698124 Member Posts: 5
    **UPDATE**

    I got past the verify error stating that there was no data type defined.
    - The fix was o create more than one column, and in the 'Column Definition' step of import i can select the name of he column, when i select something other than the first column the data type field is populated thus fixing the error during the verify step.

    But now i have a new problem. After verifying the data and clicking 'Finish' the import wizard windows closes and when i query the table the data should have been loaded into, it is empty. So the data is not be loaded into the table, without displaying any errors. I have done this with the log open and no errors are displayed in the log.

    Any suggestions? I have put in a request for IT to install the new version of SQLDeveloper, but i doubt they will get to it any time soon, so i need to find a work around.


    Thanks
  • 698124
    698124 Member Posts: 5
    installed 1.2 and import works
  • -K-
    -K- Member Posts: 6,171
This discussion has been closed.