Forum Stats

  • 3,816,034 Users
  • 2,259,132 Discussions
  • 7,893,366 Comments

Discussions

Java stored procedure NoClassDefFoundError

Ramesh_R
Ramesh_R Member Posts: 162
edited Feb 6, 2010 1:47AM in General Database Discussions
Hi All,
I have a webservice client created using Jdeveloper.
When tried to run the client in JDeveloper its running fine.
I have loaded the entire java class files into the Database.
I created a wrapper function in oracle and tried to invoke the webservice client its showing the Error
ORA- 298532: Java call terminated by uncaught java exception
java.lang.NoClassDefFoundError
I found in the user_objects and the class is available with 'VALID' status
What would be possible cause

Thanks,
Ramesh.R

Edited by: Ramesh_R on Feb 5, 2010 9:43 AM
Tagged:

Answers

  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond
    ORA- 298532
    WOW! I must have slept for a long, long time for Oracle to now have 6 digit error codes.
    What version of Oracle produced this code, because my version knows nothing about it.
  • Ramesh_R
    Ramesh_R Member Posts: 162
    Hi,
    sorry the error code is ORA 29532.
    I have loaded all the required jar files also in to the database.
    Actually i can able to connect to other webservices too, but not to a single webservice only...
    The trace for the error is
    >>
    java.lang.NoClassDefFoundError
    at HTTPClient.HTTPClientSSLFactory.class$(HTTPClientSSLFactory.java:68)
    at HTTPClient.HTTPClientSSLFactory.<clinit>(HTTPClientSSLFactory.java:69)
    >> at HTTPClient.HTTPConnection.getSSL(HTTPConnection.java:4080)
    >> at HTTPClient.HTTPConnection.getSSLSocket(HTTPConnection.java:4126)
    >> at HTTPClient.HTTPConnection.doConnect(HTTPConnection.java:3972)
    >> at HTTPClient.HTTPConnection.sendRequest(HTTPConnection.java:3007)
    >> at HTTPClient.HTTPConnection.handleRequest(HTTPConnection.java:2846)
    >> at HTTPClient.HTTPConnection.setupRequest(HTTPConnection.java:2638)
    >> at HTTPClient.HTTPConnection.Post(HTTPConnection.java:1110)
    >> at oracle.soap.transport.http.OracleSOAPHTTPConnection.post(OracleSOAPHTTPConnection.java:904)
    >> at oracle.soap.transport.http.OracleSOAPHTTPConnection.send(OracleSOAPHTTPConnection.java:713)
    >> at org.apache.soap.messaging.Message.send(Message.java:125)
    >>
This discussion has been closed.