Forum Stats

  • 3,813,740 Users
  • 2,258,765 Discussions
  • 7,892,391 Comments

Discussions

ORA-01012: not logged on

kkrm333
kkrm333 Member Posts: 531
edited Aug 23, 2010 1:27PM in General Database Discussions
Hi,

I am getting this error after login as sysdba.
and also not able to connect using any other user.
my database is up and running.

What is the reason?

Please check this

sqlplus system/manager

SQL*Plus: Release 11.2.0.1.0 Production on Tue Mar 2 02:21:23 2010

Copyright (c) 1982, 2009, Oracle. All rights reserved.

$ sqlplus '/as sysdba'

SQL*Plus: Release 11.2.0.1.0 Production on Tue Mar 2 02:21:51 2010

Copyright (c) 1982, 2009, Oracle. All rights reserved.

Connected.
SQL> desc v$instance;
ERROR:
ORA-01012: not logged on


Thanks,
Kavitha
«1

Answers

  • 671721
    671721 Member Posts: 2
    pls provide alert_$sid.log info for analyze

    tks
  • Girish Sharma
    Girish Sharma Member Posts: 4,980 Bronze Crown
    Possible solutions:

    1.set proper oracle_sid and oracle_home <its case sensetive, because you are using linux>.

    2.There's no much you can do, except drop some session so that you can connect as sysdba and increase processes. Need re-bounce; due to limit of parameter processes hit. Sessions and processes may reach the max value.
    Source:570653

    3.Copy and paste; how and what exactly you are doing to log on the db, so that we may find where else is the issue.

    Regards
    Girish Sharma
  • kkrm333
    kkrm333 Member Posts: 531
    Hi,

    While startup, I got the following error

    ORA-24324: service handle not initialized
    ORA-24323: value not allowed
    ORA-03113: end-of-file on communication channel


    After installation of latest version of 11g,
    I have created initsid.ora with following paramets. Do I need to add any more parameters?
    Please check.


    db_name='oraqa'
    memory_target=1G
    processes = 150
    audit_file_dest='/oraweb/admin/oraweb/adump'

    audit_trail ='db'
    db_block_size=8192
    db_domain=''
    db_recovery_file_dest='/oraweb/recovery_area/flash_recovery_area'
    db_recovery_file_dest_size=2G
    diagnostic_dest='/oraweb'
    dispatchers='(PROTOCOL=TCP) (SERVICE=ORCLXDB)'
    open_cursors=300
    remote_login_passwordfile='EXCLUSIVE'
    undo_tablespace='UNDOTBS1'
    # You may want to ensure that control files are created on separate physical
    # devices
    control_files = (ora_control1, ora_control2)
    compatible ='11.2.0'


    Thanks,
    Kavitha
  • kkrm333
    kkrm333 Member Posts: 531
    And the alert log showing

    ORA-07445: exception encountered: core dump [PC:0x1BC35E] [SIGSEGV] [ADDR:0x68747541] [PC:0x1BC35E] [Address not mapped to object] []


    And the trace file showing

    Error Descriptor: ORA-7445 [PC:0x1BC35E] [SIGSEGV] [ADDR:0x68747541] [PC:0x1BC35E] [Address not mapped to object] [] [] [] [] [] [] []

    Thanks,
    Kavitha
  • cnester
    cnester Member Posts: 4 Blue Ribbon
    kavi,

    Did you ever get a solution to the issues in your last two posts? I am having the same problem. I have just installed Oracle 11gR2 (11.2.0) onto a Red Hat Enterprise 4 (32-bit) server. When trying to do a startup command I get the errors:

    ORA-24324: service handle not initialized
    ORA-24323: value not allowed
    ORA-03113: end-of-file on communication channel

    The in the alert.log I see this messages along with numerous trace files and core dumps:

    ORA-07445: exception encountered: core dump [PC:0x41035E] [SIGSEGV] [ADDR:0x68747541] [PC:0x41035E] [Address not mapped to object] []

    Any assistance would be greatly appreciated, I'm stumped!
  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond
    is any type of Operating System Virtualization installed on this system?
  • cnester
    cnester Member Posts: 4 Blue Ribbon
    No, this is on physical hardware. There is no virtualization.
  • gjilevski1
    gjilevski1 Member Posts: 454 Red Ribbon
    Hi,

    database not starting up with errors ORA-01092 ORA-24324 ORA-01041 [ID 779356.1]

    Regards,
  • cnester
    cnester Member Posts: 4 Blue Ribbon
    edited Aug 12, 2010 7:13PM
    Thanks for the suggestion, but note: 779356.1 is not applicable to my situation. I do not have any datafiles in recovery. I installed 11gR2 in order to perform a test upgrade from 10.2.0. I can still open the database in 10.2.0, just fine and I've checked for datafiles in recovery already.

    I also created an init.ora for brand new database and attempted a "startup nomount" and got the exact same errors. So the issue does not lie in the database itself, since I got the same error before even creating the physical database in that particular situation.

    Edited by: user6190648 on Aug 12, 2010 4:12 PM
  • cnester
    cnester Member Posts: 4 Blue Ribbon
    edited Aug 23, 2010 12:59PM
    After putting in an SR with Oracle Support I was able to get a resolution to my issue. The problem stems from the fact that we have 32-bit Linux running on 64-bit AMD processors and there are bugs related to this.

    Applying the following patch resolved the issue entirely and the error message went away:
    8670579 , “NETCA/DBCA FAILED WITH HOTSPOT VIRTUAL MACHINE”.

    Edited by: cnester on Aug 23, 2010 9:59 AM
This discussion has been closed.