This site is currently read-only as we are migrating to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 31st, when you will be able to use this site as normal.

    Forum Stats

  • 3,890,899 Users
  • 2,269,649 Discussions


Help: Reinstall caused J3D to not use Hardware acceleration

843799 Member Posts: 49,999
edited Jan 3, 2002 10:05PM in Java 3D
System Specs: AMD Athlon 1400MHz, GeForce 2 MX 400 & ATI Rage32 (dual monitor), Windows 98, 256MB DRAM

I've been trying to figure out whether to use C++ or Java3D for an upcoming project. So I downloaded and installed J3D. I got 300+ frames/sec on the J3DFly demo application. Video performance was the only thing holding me back from using Java, so after seeing the J3DFly results, I decided to use Java.
In preparation to the project, I tore out my previous Java installations (Sun and IBM) and did a fresh re-install of Java 1.3.1_02 SDK and Java3D 1.2.1 OpenGL SDK. Swell. Re-ran the J3DFly program and got >>5<< FPS. ?!?!?
I've done everything that I can think of: switched to DirectX, tried to force hardware rendering, tried fresh re-installs. No luck.

- Anyone have any idea what happened or how to fix it?
- What framerates are people seeing on the J3DFly with the City scene?
- Is there any way that Java3D is not installing the proper hardware-accelerated DLL?
- Could my second non-3D accelerated graphics card be screwing Java3D up?



  • 843799
    843799 Member Posts: 49,999
    Have you checked if it might be the default JVM implementation used by the 'java' command? Sun actually has 3 different implementations of the Java Virtual Machine - classic, hotspot client, and hotspot server. For Sun's 1.3.1 Java SDK the Hotspot Client JVM is the default, whereas Sun's 1.2.2 Java SDK always uses the Classic JVM. Do a "java -version" to see which JVM is the default one and a "java -classic" to use the classic JVM for 1.3.1. You can also do a "java -classic -version" to verify that "-classic" works.
  • 843799
    843799 Member Posts: 49,999
    Have you checked if it might be the default JVM
    implementation used by the 'java' command? Sun
    Thank you for the suggestion. I am using Java 1.4b3 and just ran the "java -version" command. It reports that I'm using HotSpot.
    I also had these problems with Java 1.3.1_02.
    I'm also finding that J3DFly won't even install under my Java 1.4b3/ J3D 1.3 setup.
    This is getting tremendously frustrating! The first time I ran Java3D, it worked marvelously!
    Does anyone know how to check the J3D engine to see what type of rendering it is using? Any way to check on various performance parameters? I didn't see anything like that in the API.

    - Alson
  • 843799
    843799 Member Posts: 49,999
    A while ago java3d seemed to stop using my 3d card for no apparent reason (GeForce 2 GTS) and eventually i tracked it down to updating my graphics card drivers. With the latest couple of revisions from nVidia (XP and 12.81 i think) they cause problems, so i went back to the 12.41 drivers (probably the fastest and most stable on my system anyway) and java3d started working properly again.

    Since you mention you've got a GeForce 2 card, this could be the problem. Something else to check at any rate...
  • 843799
    843799 Member Posts: 49,999
    Try setting the j3d.debug property to true with the DirectX version of Java3D and check out this page on the site. I am using OpenGL Java3D and haven't tried any of this, but I just happened to stumble across this page on the site and thought it might prove helpful to you (or it might not).
  • 843799
    843799 Member Posts: 49,999
    Okay, courtesy of OrangyTang I've got my system working... sort of. I remembered that I had updated my drivers. I went and cleaned out the old drivers and installed the 12.90 drivers. Turns out I screwed up OpenGL, so I switched the Java3D to DirectX and it works pretty well. Not as fast as OpenGL, but that's okay.

    Thanks for the update on the DirectX options. I'll definitely turn on the debug to see what's going on.

    Thanks all,
This discussion has been closed.