This site is currently read-only as we are migrating to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 31st, when you will be able to use this site as normal.

    Forum Stats

  • 3,890,899 Users
  • 2,269,649 Discussions


Installation problem - urgent, PLEASE help!!

843799 Member Posts: 49,999
edited Aug 3, 2001 4:50PM in Java 3D
I'm trying to install Java3D and somehow it doesn't seem to be working. I'm not sure whether I should be installing the opengl or the
directx version, but I've tried both with no luck. I'm running Windows

I downloaded the JSDK beta 1.4 version (I have previously tried also
with the 1.3 version, this didn't work either), and now have the
jdk1.3.1 as a folder on my C drive ( C:\jdk1.3.1) . Then I downloaded
Java3D from the website, onto C, as an executable file. When I clicked
it, it went through the installation process (not giving me any
options for where to install it, i was just clicking on 'next') and
seemed to complete ok, but I'm trying to test it by running the
helloUniverse demo, and the file isn't even there. There's a Java3D
folder which has been created in Windows, but this just contains a
folder called uninstall_info.

On my Java plug-in control Panel, it is currently set to 'use java
plug-in default'. The other options are to use JRE or JDK, in folders
Program Files\JavaSoft or JDK1.3.1 respectively. I don't know which
one I should be choosing! I think I tried it with the JDK option
before and that didn't work either.

If anyone can please help I'd be really grateful, this is getting
quite urgent!


  • 843799
    843799 Member Posts: 49,999
    Hi there!

    Well, try installing java3d in the same directory as ur java(which is c:\jdk1.3.1 for u).

    If i am not mistaken, java3d, by default, installs in c:\jdk1.2.2 directory.

    U also have 2 set the path and classpath in the autoexec.bat to addr to \bin and \lib sub-directories resp.
  • 843799
    843799 Member Posts: 49,999
    OK, this is a known problem with the J3D installer and Windows ME. I (along with many others) have had the same problem. I believe someone came up with a workaround, try searching the forum for previously posted topics. I eventually had to copy the 6 J3D files off of another computer manually.
This discussion has been closed.