Forum Stats

  • 3,873,391 Users
  • 2,266,548 Discussions
  • 7,911,524 Comments

Discussions

Install 3rd party emulator in Java ME SDK 3.0

843851
843851 Member Posts: 19,484
edited Apr 21, 2009 10:26AM in Java ME SDK
Hi!
I have just uppgraded from the EA release to 3.0. When I had the EA release I added a number of 3rd party emulators to be able to run my midlet with the 'Run With' command. Now I can't get the emulators installed.

I try Tools/Java Platform/Add Platform. I have tried with both 'Java ME MIDP Platform Emulator' and 'Custom Java ME MIDP Platform Emulator' but no Java ME Platform folders can be found. Should my existing emulators, that worked with the EA release work, or do I need new versions? What 3rd party emulators hav you tested this with??

br

Erik Wetterberg

Comments

  • 843851
    843851 Member Posts: 19,484
    Hello Erik,

    thank you for your comment.

    The UI which comes with Jame ME SDK 3.0 is supposed to be a small IDE for Java ME SDK 3.0. It means it does not support emulators which are not Java ME SDK 3.0 compliant. That's probably your case.

    Detecting not Java ME SDK 3.0 compliant 3rd party emulators and "Run With" command was a side effect of EA release which was removed for final version. In final release it is not possible to detect not 3.0 compliant toolkits anymore, e.g. Sun Java Wireless Toolkit 2.5.2 for CLDC or Sun Java Toolkit 1.0 for CDC.

    If you want to use 3rd party emulators use NetBeans Mobility. It is supposed to support all emulators which can be detected by UEI.

    Best regards,
    Radko
This discussion has been closed.