Forum Stats

  • 3,827,849 Users
  • 2,260,830 Discussions
  • 7,897,398 Comments

Discussions

PHP 4.3.2 on Linux 9 (using Oracle 9 client libraries)

402352
402352 Member Posts: 2
edited Sep 3, 2003 12:51PM in PHP
I've been using PHP on Windows for Oracle 8.1.7 for a long time and it's a fantastic combination. The setup is easy and it works like a charm. However, the time has come to get it working on Linux so I can put applications and tools into a production environment.

No matter how closely I've followed instructions, I've had several problems with the installation procedure. Firstly, I cannot get the Oracle 8 installer to even run so I've installed the Oracle 9 client libraries instead. Secondly, once I've compiled PHP 4.3.2 with Apache 1.3.28, I get a problem when retrieving strings: dates, integers, clobs are all fine. My conclusion seems to be that this is a characterset conflict because when I run PHP on it's own, strings come out fine. Also, when changing the NLS_LANG setting to an invalid characterset (in my case english_united kingdom.WE8ISO5559P1), I get a segmentation fault (english_united kingdom.UTF8 works fine).

When I run it through Apache, I get two different errors when ordering the select columns differently.

e.g. select [integer], [clob], [varchar2] from table
returns an ORA-03106 error

and select [integer], [varchar2], [clob] from table
returns an ORA-24813 error

Any help or advice would be greatly appreciated. Whilst this doesn't appear to be an Oracle problem, it's a severe obstacle whilst trying to prove this is a viable technology option - hopefully this has been encountered before. Thanks a lot.

Comments

This discussion has been closed.