Forum Stats

  • 3,826,778 Users
  • 2,260,707 Discussions
  • 7,897,072 Comments

Discussions

Linked Server in SQL 2008

818883
818883 Member Posts: 2
edited Dec 29, 2010 2:09PM in Oracle Provider for OLE DB
Hi,

Do I only have to install the Oracle 11g Release 2 ODAC 11.2.0.1.2 software to establish a connection beetwen SQL and Oracle?
Do I need to restart the SQL service as well?

I do not have the "OraOLEDB.Oracle" Provider in my SQL linked server list though i have installed the ODAC components (including Instant client)

I am just starting with Oracle so sorry for this basic questions. If anybody knows something please let me know!!
Doese anyone have a documentation for configurung SQL Server for that?

Thank you very much, Daniel

Answers

  • 818883
    818883 Member Posts: 2
    Hi,

    I have just figured out I don't need a link Server.

    I would like to connect my SSIS Project with Oracle. What I have installed so far:

    * AttunitySSIS (Oracle Integration in SSIS Projects
    * ODAC Driver

    I dont see the Oracle ODBC drivers right now. Do you know what is wrong?
    What I did (dont know if this was clever)

    * uninstalled the Oracle Client 11g
    * removed the ODBC settings in the registry since I was ont able to remove them in an other way ( I had two entries, one for the 11g client and one for the ODAC and neither was working)

    Do I need to uninstall all and reboot the machine?
    Do you know how to make the ODBC driver run again?

    Does anybody have an idea? Thanks a lot,
    Daniel
  • 820400
    820400 Member Posts: 2
    These people do not respond to any requests... I have looked for information regarding this and found nothing.
  • 827369
    827369 Member Posts: 1
    Daniel,

    did you figure out what you need to get your SSIS project working? I'm in the process of getting this set up and keep hitting walls. Do I need to set up a linked server?

    Although my MS stuff is 64 bit on a Win Server 2008 R2, my Oracle app runs on 10G R3.

    CB
This discussion has been closed.