Forum Stats

  • 3,768,285 Users
  • 2,252,771 Discussions
  • 7,874,515 Comments

Discussions

Tabular form apex 4.0.2, inline validation causin problems

793369
793369 Member Posts: 2
edited Dec 8, 2010 7:30AM in APEX Discussions
I have a tabular form with a simple query like

select xxx,xxx from tableA where id=:P2_xxx+

Whenever I change a column with a invalid entry the (inline) validation returns an error what is OK of course, but I also receive this message in the tabular region:

"Current tabular form data is too old; the source data has been modified.
Click here to discard your changes and reload the data from the database."

When I change the inline validation to an 'error-page'-validation, I don't have these problems
When I change the query to select xxx,xxx from tableA (without where-clause with item), I don't have the problems.

I just tried it at home with apex 4.0.0 and there I don't have the problems and are the validation working as well.

Is this a bug or am I missing something?
Tagged:

Answers

  • 793369
    793369 Member Posts: 2
    edited Dec 8, 2010 7:30AM
    The problem is the unique index on the table for the field ID (by the way, this ID was not the pk). Changed the order of the columns in the uk, so the ID was not the first column. This solved the problem.

    Edited by: Agekay on 8-dec-2010 4:30
This discussion has been closed.