Forum Stats

  • 3,726,961 Users
  • 2,245,298 Discussions
  • 7,852,511 Comments

Discussions

Oracle 11g R2 installation, sqlplus only connects to idle instance??

836483
836483 Member Posts: 8
edited February 2011 in Database Installation
Hello, I have just downloaded and installed OR11G R2 on a VM (linux Redhat 8). I tried sqlplus connection to oracle but it only connects to an idle instance. I am very new to both Linux and Oracle so I have not been able to figure it out even after reading a lot of threads online. I followed the link below for installation guide from beginning to end, and only changed the host from viper to localhost (is that the problem??).

http://www.oramoss.com/wiki/index.php/Install_OBIEE_11.1.1.3.0_on_Oracle_Enterprise_Linux_5.5_with_Oracle_11gR2_RDBMS.

I didn't what more information to post here, but please tell me how and what information you need, to may be try and fix this issue.
Thanks alot

[[email protected] ~]$ sqlplus sys as sysdba

SQL*Plus: Release 11.2.0.1.0 Production on Tue Feb 15 16:09:03 2011

Copyright (c) 1982, 2009, Oracle. All rights reserved.

Enter password:
Connected to an idle instance.

SQL> selct * from v$version
SP2-0734: unknown command beginning "selct * fr..." - rest of line ignored.
SQL> select * from v$version;
select * from v$version
*
ERROR at line 1:
ORA-01034: ORACLE not available
Process ID: 0
Session ID: 0 Serial number: 0


SQL> startup
ORA-01078: failure in processing system parameters
LRM-00109: could not open parameter file '/u01/app/oracle/product/11.2.0/db_1/dbs/initDB11G.ora'
3408363

Best Answer

  • OrionNet
    OrionNet Member Posts: 4,542
    Accepted Answer
    Hello,



    Start your database and monitor alert.log in another terminal window to see if your database opens up without any problem. Address any issue reported during manual startup or automated startup(alert.log). Then follow direction provided in the oracle 11g documentation to startup listener and oracle database after system reboot.

    http://download.oracle.com/docs/cd/E11882_01/server.112/e10839/strt_stp.htm#sthref129
     $> sqlplus '/as sysdba'
     SQL> startup;
    Regards
    OrionNet

Answers

  • damorgan
    damorgan Member Posts: 14,464
    It is, from my experience, impossible for your situation to be as you describe.

    Has a previous installation of Oracle been made on this machine? Is it pointed to by environment variables such as ORACLE_HOME and/or ORACLE_SID?
    3408363
  • EdStevens
    EdStevens Member Posts: 28,024 Gold Crown
    user13543219 wrote:
    Hello, I have just downloaded and installed OR11G R2 on a VM (linux Redhat 8). I tried sqlplus connection to oracle but it only connects to an idle instance. I am very new to both Linux and Oracle so I have not been able to figure it out even after reading a lot of threads online. I followed the link below for installation guide from beginning to end, and only changed the host from viper to localhost (is that the problem??).
    That's probably not the cause of your current problem ... but even in a vm on your laptop ( I have a whole computer lab in vm's on my laptop) you wouldn't want to name your server 'localhost'. "localhost" is practically a reserved word. By default, your local 'hosts' file (used to resolve a name to an IP address) will have an entry like this:
    127.0.0.1 localhost.localdomain localhost
    You would want to add another line:
    192.168.160.101 vmlnx01.vmdomain vmlnx01
    of course, using your own static ip of the machine, and its real name and domain.

    >
    http://www.oramoss.com/wiki/index.php/Install_OBIEE_11.1.1.3.0_on_Oracle_Enterprise_Linux_5.5_with_Oracle_11gR2_RDBMS.

    I didn't what more information to post here, but please tell me how and what information you need, to may be try and fix this issue.
    Thanks alot

    [[email protected] ~]$ sqlplus sys as sysdba

    SQL*Plus: Release 11.2.0.1.0 Production on Tue Feb 15 16:09:03 2011

    Copyright (c) 1982, 2009, Oracle. All rights reserved.

    Enter password:
    Connected to an idle instance.

    SQL> selct * from v$version
    SP2-0734: unknown command beginning "selct * fr..." - rest of line ignored.
    SQL> select * from v$version;
    select * from v$version
    *
    ERROR at line 1:
    ORA-01034: ORACLE not available
    Process ID: 0
    Session ID: 0 Serial number: 0


    SQL> startup
    ORA-01078: failure in processing system parameters
    LRM-00109: could not open parameter file '/u01/app/oracle/product/11.2.0/db_1/dbs/initDB11G.ora'
    The only way I can see that happening is to have a bad value for ORACLE_SID. In fact, I just reproduced your error exactly, by deliberately setting ORACLE_SID to a bogus value.
    [[email protected] ~]$ export ORACLE_SID=foobar
    [[email protected] ~]$ sqlplus / as sysdba
    
    SQL*Plus: Release 10.2.0.4.0 - Production on Tue Feb 15 17:26:35 2011
    
    Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.
    
    Connected to an idle instance.
    
    SQL> startup
    ORA-01078: failure in processing system parameters
    LRM-00109: could not open parameter file '/ora00/app/oracle/product/10.2.0/db_1/dbs/initfoobar.ora'
    SQL>
    Do the above again, only this time, just before starting sqlplus, enter these commands exactly as you see them here (cut and paste is your friend)
    env|grep ORA|sort
    cat /etc/oratab
    ps -ef|grep pmon
    Copy the entire session -- commands and results -- and paste back here.
    3408363
  • 836483
    836483 Member Posts: 8
    I have Oracle 10G installed on another VM (Win XP) on the same machine and also on the main original machine (Win 7).
  • 836483
    836483 Member Posts: 8
    This is what I got as a result of the commands you listed above, I am starting to see your point, though. Hope this gives you the information you are asking for.

    [[email protected] ~]$ env|grep ORA|sort
    ORACLE_BASE=/u01/app/oracle
    ORACLE_HOME=/u01/app/oracle/product/11.2.0/db_1
    ORACLE_HOSTNAME=localhost
    ORACLE_SID=DB11G
    ORACLE_TERM=xterm
    ORACLE_UNQNAME=DB11G
    [[email protected] ~]$ cat /etc/oratab
    #



    # This file is used by ORACLE utilities. It is created by root.sh
    # and updated by the Database Configuration Assistant when creating
    # a database.

    # A colon, ':', is used as the field terminator. A new line terminates
    # the entry. Lines beginning with a pound sign, '#', are comments.
    #
    # Entries are of the form:
    # $ORACLE_SID:$ORACLE_HOME:<N|Y>:
    #
    # The first and second fields are the system identifier and home
    # directory of the database respectively. The third filed indicates
    # to the dbstart utility that the database should , "Y", or should not,
    # "N", be brought up at system boot time.
    #
    # Multiple entries with the same $ORACLE_SID are not allowed.
    #
    #
    T112:/u01/app/oracle/product/11.2.0/db_1:Y
    [[email protected] ~]$ ps -ef|grep pmon
    oracle 4519 4485 0 20:40 pts/1 00:00:00 grep pmon
    [[email protected] ~]$
  • EdStevens
    EdStevens Member Posts: 28,024 Gold Crown
    user13543219 wrote:
    This is what I got as a result of the commands you listed above, I am starting to see your point, though. Hope this gives you the information you are asking for.
    Exactly the info we needed.
    [[email protected] ~]$ env|grep ORA|sort
    ORACLE_BASE=/u01/app/oracle
    ORACLE_HOME=/u01/app/oracle/product/11.2.0/db_1
    ORACLE_HOSTNAME=localhost
    ORACLE_SID=DB11G
    ORACLE_TERM=xterm
    ORACLE_UNQNAME=DB11G
    So your ORACLE_SID is set to DB11G. How did you arrive at that value? Because ...
    [[email protected] ~]$ cat /etc/oratab
    #



    # This file is used by ORACLE utilities. It is created by root.sh
    # and updated by the Database Configuration Assistant when creating
    # a database.

    # A colon, ':', is used as the field terminator. A new line terminates
    # the entry. Lines beginning with a pound sign, '#', are comments.
    #
    # Entries are of the form:
    # $ORACLE_SID:$ORACLE_HOME:<N|Y>:
    #
    # The first and second fields are the system identifier and home
    # directory of the database respectively. The third filed indicates
    # to the dbstart utility that the database should , "Y", or should not,
    # "N", be brought up at system boot time.
    #
    # Multiple entries with the same $ORACLE_SID are not allowed.

    #
    T112:/u01/app/oracle/product/11.2.0/db_1:Y
    ... there is no entry for DB11G in your oratab. Instead you have T112. In addition ....
    [[email protected] ~]$ ps -ef|grep pmon
    oracle 4519 4485 0 20:40 pts/1 00:00:00 grep pmon
    ... you have NO database running on the machine at all. That last command should have returned something like this:
    [[email protected] ~]$ ps -ef|grep pmon
    oracle    2318 16623  0 21:11 pts/0    00:00:00 grep pmon
    oracle    5277     1  0 Feb14 ?        00:00:23 ora_pmon_vlnxora1
    Only in your case, instead of 'vlnxora1' you should have seen the name of your instance.
  • 836483
    836483 Member Posts: 8
    So, I should change T112 to DB11G while running oracle networking creation and database configuration?? I did that because I followed an online oracle installation guide. Forgive me if I sound like a rookie...since I am one.
  • OrionNet
    OrionNet Member Posts: 4,542
    Accepted Answer
    Hello,



    Start your database and monitor alert.log in another terminal window to see if your database opens up without any problem. Address any issue reported during manual startup or automated startup(alert.log). Then follow direction provided in the oracle 11g documentation to startup listener and oracle database after system reboot.

    http://download.oracle.com/docs/cd/E11882_01/server.112/e10839/strt_stp.htm#sthref129
     $> sqlplus '/as sysdba'
     SQL> startup;
    Regards
    OrionNet
  • EdStevens
    EdStevens Member Posts: 28,024 Gold Crown
    user13543219 wrote:
    So, I should change T112 to DB11G while running oracle networking creation and database configuration?? I did that because I followed an online oracle installation guide. Forgive me if I sound like a rookie...since I am one.
    I have no idea where you got either value, but I'd guess the value in oratab is correct. You should get a better clue by looking at the file names in the directory $ORACLE_HOME/dbs
This discussion has been closed.