developers

    Forum Stats

  • 3,873,880 Users
  • 2,266,627 Discussions
  • 7,911,650 Comments

Discussions

dwr method fails

User_XE8NW
User_XE8NW Member Posts: 2 Blue Ribbon
when i execute my application in the eclipse ide it works fine but when it comes to browser dwr method fails to execute an im getting the following error


[Error]
Mar 15, 2011 6:29:19 PM org.directwebremoting.util.CommonsLoggingOutput info
INFO: Exec: FeeManagementSystemDWR.getCollegeList()
Mar 15, 2011 6:29:19 PM org.directwebremoting.util.CommonsLoggingOutput warn
WARNING: Method execution failed:
java.lang.NumberFormatException: null
at java.lang.Integer.parseInt(Integer.java:415)
at java.lang.Integer.<init>(Integer.java:620)
at com.mf.cms.fms.services.fmsservices.FeeManagementSystemDWR.getCollegeList(FeeManagementSystemDWR.java:23)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.directwebremoting.impl.ExecuteAjaxFilter.doFilter(ExecuteAjaxFilter.java:34)
at org.directwebremoting.impl.DefaultRemoter$1.doFilter(DefaultRemoter.java:428)
at org.directwebremoting.impl.DefaultRemoter.execute(DefaultRemoter.java:431)
at org.directwebremoting.impl.DefaultRemoter.execute(DefaultRemoter.java:283)
at org.directwebremoting.servlet.PlainCallHandler.handle(PlainCallHandler.java:52)
at org.directwebremoting.servlet.UrlProcessor.handle(UrlProcessor.java:101)
at org.directwebremoting.servlet.DwrServlet.doPost(DwrServlet.java:146)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:647)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:875)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
at java.lang.Thread.run(Thread.java:595)
Mar 15, 2011 6:29:19 PM org.directwebremoting.util.CommonsLoggingOutput warn
WARNING: --Erroring: batchId[0] message[java.lang.NumberFormatException: null]
[Error]




Please help me out in that aspect
it's urgent ...........
Thanks in advance
Thimmappa Narala

Answers

  • jschellSomeoneStoleMyAlias
    jschellSomeoneStoleMyAlias Member Posts: 24,877 Gold Badge
    844526 wrote:
    when i execute my application in the eclipse ide it works fine
    You are running in an 'environment'. That does not only consist of your code but also includes other things such as but not limited to configuration files, environment variables etc.
    but when it comes to browser dwr method fails to execute an im getting the following error
    The 'environment' is different.
    Please help me out in that aspect
    Most likely reason is that there is a configuration source (a file or value in a file), which exists in the IDE and doesn't exist when you run it outside the IDE.
  • User_XE8NW
    User_XE8NW Member Posts: 2 Blue Ribbon
    But when i build war from the eclipse and deploy that one in the jboss server it is not working
    since apache and jboss both are web servers
    how and where could be the mismatch


    i hope some jar files may be missing


    sujjest me some solution


    Regards
    Thimmappa Narala
  • jschellSomeoneStoleMyAlias
    jschellSomeoneStoleMyAlias Member Posts: 24,877 Gold Badge
    844526 wrote:
    But when i build war from the eclipse and deploy that one in the jboss server it is not working
    since apache and jboss both are web servers
    And thus they would be different environments.

    >
    i hope some jar files may be missing
    Then you would get a class not found exception.
This discussion has been closed.
developers