Forum Stats

  • 3,875,295 Users
  • 2,266,907 Discussions
  • 7,912,141 Comments

Discussions

There is no trail to reposition to when doing direct load task

user651239
user651239 Member Posts: 94 Blue Ribbon
edited Mar 30, 2011 8:25AM in GoldenGate
Hi:

i completed load the data from one database to another data base. if in target database ther eis no constraints. but when i am trying to run extract with same database with all constraints. it deisplay trail error.

Please help !!!

regards,
Abhishek

Answers

  • Abhishek,

    Probably the initial load replicat hit an error. The initial load extract will be restarted, but there are no checkpoints and no trail, so it cannot start from where it left off.
    Thats why on the extract you see the error you mentioned.
    Have a look at the report of the initial load replicat and determine the cause of the error.
    When fixed start the initial load again (you might have to delete and add the initial load extract again.

    good luck!
    Eric
  • user651239
    user651239 Member Posts: 94 Blue Ribbon
    Thanks Alot for you response Eric!!!

    Actually i created two database on the same machine. i used hr schema script for creating database. like employees, department.

    on first database orcl i ran both scripts table creation and data population. and on the other database orcl2 i run only table creation script. then run the extract it display error. dur to contraints. when i create aal the table with any constraints on the target data base. and then run this process. it working fine. it populate all the records.

    Is there any setting or set the parameter for complete schema data.

    please let me know if i am doing anything wrong.

    regards,
    Abhi
  • Abhi,

    Verify the following things;

    * the replicat is connection to the correct database
    * the mapping in the replicat is correct (especially the correct target tables)
    * the target table is empty

    so you have 2 databases on the same machine, orcl1 & orcl2 and the tables you are using are in the hr schema (in both databases).
    And if you don't specify to wich database the replicat should connect it will use the oracle sid as specified in the system variable

    So if the system variable ORACLE_SID is set to orcl1, then the replicat wil connect to orcl1 and replicate to the tables in the hr schema

    to avoid this you can place the SETENV parameter in your replicat;

    SETENV (ORACLE_SID = "orcl2")


    again, good luck! :)
  • user651239
    user651239 Member Posts: 94 Blue Ribbon
    Thanks alot Eric for your help !!!

    I checked all the above list. it is ok with my enviroment.

    Now I am using two machines with two different oracle sever.

    Actually due to constraints this error is occurred. I used hr_cre.sql script to create the tables in both database. hr_popul.sql used to load data in oracl1 database.

    When I run the extract method it terminate the process and display no trail error.

    When I create table without any constraints in orcl2 and run the process its complete process without any error and upload the data.

    Could you please tell me about trail info ?

    Regards,
    Abhishek
  • Abhishek,

    If the initial load extract abends with the no trail to reposition error, it means that the replicat has an issue, and the extract was restarted, but because there is not trail, or checkpoint it cannot reposition itself.
    So the issue is on the replicat, if you are still getting the constraint issue then there probably is already data in the target table.
    So make sure that before you start your initial load, to check if the target table is really empty.

    and to have a clean start, delete and re-add your initial load extract

    it could be that you also have a CDC extract and replicat running for capturing the online changes.
    If this is the case then when you run the hr_popul.sql script to insert data in the source, the CDC extract captures it, and replicat inserts the data into the target.
    and then you do the inital load, but the data is already there.

    regards,
    Eric
This discussion has been closed.