Forum Stats

  • 3,814,863 Users
  • 2,258,921 Discussions
  • 7,892,882 Comments

Discussions

Database Version not supported, Oracle 8 access from Windows 64 bit

650129
650129 Member Posts: 3
edited Apr 21, 2011 2:47AM in Oracle Call Interface (OCI)
Hi,

I am trying to access an Oracle DB Instance 8 from a windows 7 64 bit machine.
I am using he TNS ORA file and always the connection fails with the error:

"Database version is not supported."

I tried accessing other Oracle DB Instances (>9) and they are all accessed fine (through the SID).
Oracle 8 is the only one which is giving me problems.

The tools which i am using are Toad as well as Oracle SQL Developer.
I tried to look up the problem but the only work around i see is to install an ORACLE 10 version on the system (which i tried, with no success).

Any suggestions will be greatly appreciated.

/Best Regards
Umair

Edited by: user647126 on Mar 29, 2011 10:46 AM
Tagged:

Answers

  • 650129
    650129 Member Posts: 3
    The solution lies in the following thread:

    1012383

    As quoted:
    >

    My operating system is Windows 7 64-bit, using Office 2010 64-bit. Trying to connect to an ODBC data source through Excel. The data source is an Oracle9i 32-bit database on a Windows Server 2003 32-bit server. However, the database version or server operating system is arbitrary; it could be an 8i, 9i, 10g, or even an 11g 32-bit or 64-bit database on a UNIX or Windows server. If you're using Windows 7 64-bit and you want to connect to an ODBC data source through Excel to an Oracle database, you must use Office 2010 64-bit. You cannot use Office 2003 or 2007, for example.

    Follow these steps on your Windows 7 64-bit PC to connect to your ODBC data source.

    1. Through Oracle's web site, go to Instant Client Downloads for Microsoft Windows (x64). Currently, the address to that page is:
    http://www.oracle.com/technology/software/tech/oci/instantclient/htdocs/winx64soft.html

    2. Download the two following files, found under the version 11.1.0.7.0 heading:
    Instant Client Package - Basic (instantclient-basic-win-x86-64-11.1.0.7.0.zip)
    Instant Client Package - ODBC (instantclient-odbc-win-x86-64-11.1.0.7.0.zip)

    3. Extract both zip files to the same directory (such as c:\oracle\instantclient_11_1).

    4. Launch the Command Prompt (DOS command window) by running it as administrator. Go to Start > All Programs > Accessories, then right click Command Prompt and select Run as Administrator.

    5. From within the Command Prompt, navigate to c:\oracle\instantclient_11_1, and run odbc_install.exe. You should receive a message saying Oracle ODBC Driver is installed successfully. The name of the new ODBC driver that was just installed is Oracle in instantclient11_1 -- use this driver when creating your ODBC connection.

    6. Create a new system environment variable. Set the value of the variable name as TNS_ADMIN, and the value of the variable path as the directory that contains the tnsnames.ora and sqlnet.ora files. On my PC, I have another Oracle client already installed which has its own tnsnames.ora and sqlnet.ora files. Therefore, I set the value of variable path as c:\orant\net80\admin (the directory that contains my tnsnames.ora and sqlnet.ora files). If you don't have another Oracle client installed on your PC, create a new directory such as c:\oracle\instantclient_11_1\network\admin, and place the tnsnames.ora and sqlnet.ora files in that directory. Then, set c:\oracle\instantclient_11_1\network\admin as the value for the variable path.

    7. To create the ODBC connection, go Start > Control Panel > Administrative Tools > Data Sources (ODBC). Alternatively, you can create the connection right from within Excel.
  • 650129
    650129 Member Posts: 3
    edited Mar 29, 2011 10:26AM
    But now i have another problem.
    The ODBC connection is now throwing this error message:

    Unable to connect+
    SQLState=S1000+
    +*[Oracle][ODBC][Ora]ORA-03134: Connections to this server version are no longer supported.*+


    The installed client version is 11 on a 64 bit machine and trying to access an Oracle instance of 8.
    No clue as what the problem could be.

    Edited by: user647126 on Mar 29, 2011 4:22 PM
  • Vincent Rogier
    Vincent Rogier Member Posts: 185
    edited Mar 30, 2011 2:15AM
    Hi,


    A Oracle 11g client cannot connect to an Oracle 8i server. It clearly stated in the Oracle version compatibility matrix.

    8i client can connect to any server from 7.3.4 to 11g
    9iR1 client can connect to any server from 7.3.4 to 11g
    9iR2 client can connect to any server from 8.1.7 to 11g
    10g client can connect to any server from 8.1.7 to 11g (with some sub version not supported)
    11g client can connect to any server from 9iR2 to 11g
  • 11g client can only connect to 9ir2 onwards and hence the error.
This discussion has been closed.