Forum Stats

  • 3,734,267 Users
  • 2,246,934 Discussions
  • 7,857,216 Comments

Discussions

Tableadapters giving "Incorrect parameter" error

877531
877531 Member Posts: 3
I am using Visual Studio 2010 and Oracle 11g 11.2.0.1 and ODAC 11.2.0.1.2 tools for VS 2010 on a Windows Server 2008 R2. Previously I had all my tableadapters working without a problem but then I reformatted my HD and even though I installed all the same software I am getting errors. I use the tableadapter query to write the SQL then I test it but I get an incorrect paramter error, however this only happens on number or date columns not char columns. For example this is one of my SQL statements that show the error:

SELECT * FROM Employees WHERE empID = :id (the : tells VS2010 that it is an Oracle paramter)

when I try the next SQL statement everything works fine.

SELECT * FROM Employees WHERE empFName = :fName

As I said before everything worked before I reformatted but not now. I thought it was just me so I have reformatted twice more and each time I get the same error. Anybody have any idea why this has changed.

Answers

This discussion has been closed.