Forum Stats

  • 3,874,962 Users
  • 2,266,788 Discussions
  • 7,912,033 Comments

Discussions

Java Desktop API broken on windows?

809103
809103 Member Posts: 2
edited Nov 14, 2011 12:47PM in Java Desktop Applications
From what I can tell no-one has actually been able to get this API to work properly..

Desktop dtop = Desktop.getDesktop();
dtop.open(new File("/test.mp3"));

always results in the error:
Exception in thread "main" java.io.IOException: Failed to open file:/D:/TMP/test.mp3. Error message: Unspecified error

at sun.awt.windows.WDesktopPeer.ShellExecute(Unknown Source)
at sun.awt.windows.WDesktopPeer.open(Unknown Source)
at java.awt.Desktop.open(Unknown Source)
at com.test.Test.<init>(Test.java:50)
at com.test.Test.main(Test.java:103)
ERROR: JDWP Unable to get JNI 1.2 environment, jvm->GetEnv() return code = -2
JDWP exit error AGENT_ERROR_NO_JNI_ENV(183): [../../../src/share/back/util.c:820]

I've tried using browse, as well no luck.
and yes (I can open the file directly, and yet..its is associated, and I've run the process as admin -- yes this on a windows 7 x64 machine).

its works fine for .txt files.

I have seen various postings on bugs related to this..but mysteriously those bugs have 'vanished' from the system.

Answers

  • User_64CKJ
    User_64CKJ Member Posts: 7,279 Silver Badge
    <tt>Desktop.open()</tt> works fine here with MP3s (or at least, the first MP3 I tried). The track opened in WinAmp, the default consumer for MP3s.
  • We are seeing the same thing with PDF files. It works the vast majority of the time, but it occasionally breaks. If it's not working, it will not work every time on that machine. If it works, it seems like it works consistently.

    So it does seem like the issue is limited to some sort of Windows/Java combination.
This discussion has been closed.