Forum Stats

  • 3,817,474 Users
  • 2,259,340 Discussions
  • 7,893,791 Comments

Discussions

Import from Oracle DB using SSIS is failing

913164
913164 Member Posts: 2
edited Jan 27, 2012 2:53AM in Oracle Provider for OLE DB
We are able to connect to Oracle (10g) DB using 64 bit Oracle 11g Client and successfully execute the SSIS package using BIDS. But if we try to execute the same through code which is using a DTSEXEC utility to execute the package we are getting an ‘Execute Failure’ status.

Could you please advise what could be wrong?
20a6efa9-3b9e-4527-8d56-d291ed1a7df7

Answers

  • orafad
    orafad Member Posts: 8,035 Silver Trophy
    The component you are calling may not be 64-bit (and I believe DTS exist as both 32 and 64-bit executable). If it is 32-bit, thus needing 32-bit libraries, it may explain "execute failure".
    orafad
  • 913164
    913164 Member Posts: 2
    I tried the suggestion provided by you. It gives an error while connection establishment. If I use the 64 bit DTexec utility to execute the same package it connects but throws an internal data conversion error. I even tried to run the package through Execute package utility in SQL Server it is also not working. The same package runs perfectly fine in the development server having 32 bit Oracle Client.

    Please advise.
This discussion has been closed.