This site is currently read-only as we are migrating to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,890,115 Users
  • 2,269,775 Discussions
  • 7,916,823 Comments

Discussions

[INS-20802] Oracle Net Configuration Assistant failed

947157
947157 Member Posts: 33
edited Jul 19, 2012 4:24PM in Database Installation
I've spent hours on this. Further to my previous thread, I got this error because I was using RHEL6.3. I have installed a new Oracle Linux 5.8 server, gone through the PreReqs and I now get the same error again. Very frustrating. I am installing 11.2.0.1 x64 on OEL 5.8 x64. Here's the error: http://i.imgur.com/WWF1X.png

What am I doing wrong now? I followed the guide here to install the Oracle Linux Server: http://www.oracle-base.com/articles/11g/oracle-db-11gr2-installation-on-oracle-linux-5.php
«134

Answers

  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond
    can you successfully complete both OS commands below?

    ping <hostname>
    ping <IP#>
  • 947157
    947157 Member Posts: 33
    I ran these commands on the server:

    [[email protected] ~]# ping nitrogen
    PING nitrogen.localdomain (127.0.0.1) 56(84) bytes of data.
    64 bytes from nitrogen.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.020 ms


    [[email protected] ~]# ping 10.0.0.7
    PING 10.0.0.7 (10.0.0.7) 56(84) bytes of data.
    64 bytes from 10.0.0.7: icmp_seq=1 ttl=64 time=0.018 ms

    Both worked fine.
  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond
    keymoo wrote:
    I ran these commands on the server:

    [[email protected] ~]# ping nitrogen
    PING nitrogen.localdomain (127.0.0.1) 56(84) bytes of data.
    64 bytes from nitrogen.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.020 ms


    [[email protected] ~]# ping 10.0.0.7
    PING 10.0.0.7 (10.0.0.7) 56(84) bytes of data.
    64 bytes from 10.0.0.7: icmp_seq=1 ttl=64 time=0.018 ms

    Both worked fine.
    no, you do not understand.
    hostname & IP# are matched pair

    post results from following OS commands

    hostname
    uname -a
    cat /etc/hosts
    ifconfig

    COPY commands & results then PASTE all back here
    sb92075
  • 947157
    947157 Member Posts: 33
    Thanks for the help.


    [[email protected] ~]# hostname
    nitrogen.localdomain
    [[email protected] ~]# uname -a
    Linux nitrogen.localdomain 2.6.32-300.10.1.el5uek #1 SMP Wed Feb 22 17:37:40 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
    [[email protected] ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 nitrogen.localdomain nitrogen localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    10.0.0.7 nitrogen.localdomain nitrogen
    [[email protected] ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0C:29:3D:19:55
    inet addr:10.0.0.7 Bcast:10.0.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:27618 errors:0 dropped:0 overruns:0 frame:0
    TX packets:811 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3190846 (3.0 MiB) TX bytes:76667 (74.8 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:910 errors:0 dropped:0 overruns:0 frame:0
    TX packets:910 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2316796 (2.2 MiB) TX bytes:2316796 (2.2 MiB)
  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond
    hostname "nitrogen.localdomain" should only resolve to single IP#

    when 127.0.0.1 is used, then no remote client can connect to this system;
    which is not necessarily a bad thing.
    [email protected]:~$ hostname
    bcm-laptop
    [email protected]:~$ uname -a
    Linux bcm-laptop 2.6.32-41-generic #91-Ubuntu SMP Wed Jun 13 11:43:55 UTC 2012 x86_64 GNU/Linux
    [email protected]:~$ cat /etc/hosts
    127.0.0.1	localhost bcm-laptop
    [email protected]:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:1e:68:a1:ad:67  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:17 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:424 errors:0 dropped:0 overruns:0 frame:0
              TX packets:424 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:23588 (23.5 KB)  TX bytes:23588 (23.5 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:21:63:2b:63:ac  
              inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::221:63ff:fe2b:63ac/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:40896 errors:0 dropped:0 overruns:0 frame:0
              TX packets:38286 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:31655589 (31.6 MB)  TX bytes:11516497 (11.5 MB)
    
    [email protected]:~$ 
  • Srini Chavali-Oracle
    Srini Chavali-Oracle Member Posts: 29,596 Employee
    Pl also post the last 50 lines from the log file in your screenshot

    HTH
    Srini
  • 947157
    947157 Member Posts: 33
    edited Jul 15, 2012 12:10PM
    I reverted to my VM snapshot and tried the database install again. I changed my /etc/hosts file to this before the install

    [[email protected] ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    10.0.0.7 nitrogen.localdomain nitrogen


    I get the same error.


    Here's the log file from the screenshot
    [[email protected] ~]# tail -50 /app/oraInventory/logs/installActions2012-07-15_04-52-50PM.log
    INFO: Setting value to transient variable s_asmsnmpPasswordFlag
    INFO: Setting value to transient variable S_DBSNMPPASSWORD
    INFO: Setting value to transient variable s_dbsnmpPasswordFlag
    INFO: Setting value to transient variable S_ASMSNMPPASSWORD
    INFO: Setting value to transient variable S_SYSTEMPASSWORD
    INFO: Setting value to transient variable s_hostUserPasswordFlag
    INFO: Updating Transient Parameters for OuiConfigVariables
    INFO: Updating Transient Parameters for oracle.sysman.ccr
    INFO: Updating Transient Parameters for oracle.sysman.console.db
    INFO: Successfully updated Transient Parameters in the Aggregates
    INFO: Configuration log directory - /app/oracle/product/11.2.0/db_1/cfgtoollogs
    INFO:
    The Runconfig command constructed is /app/oracle/product/11.2.0/db_1/oui/bin/runConfig.sh ORACLE_HOME=/app/oracle/product/11.2.0/db_1 MODE=perform ACTION=configure RERUN=true $*
    INFO: Created a new file /app/oracle/product/11.2.0/db_1/cfgtoollogs/configToolAllCommands
    INFO: Since the option is to overwrite the existing /app/oracle/product/11.2.0/db_1/cfgtoollogs/configToolAllCommands file, backing it up
    INFO: The backed up file name is /app/oracle/product/11.2.0/db_1/cfgtoollogs/configToolAllCommands.bak
    INFO: Entering ConfigClient.executeToolsInAggregate method
    INFO: ConfigClient.executeToolsInAggregate oAggregate=oracle.server:oracle.server:11.2.0.1.0:common
    INFO: Entering ConfigClient.assignAction method
    INFO: ConfigClient.assignAction actionref=[Loracle.sysman.emCfg.common.IActionReference;@258361f6
    INFO: ConfigClient.assignAction action is of type :configuration
    INFO: Exiting ConfigClient.assignAction method
    INFO: ConfigClient.executeToolsInAggregate action assigned
    INFO: Started Plugin named: Oracle Net Configuration Assistant
    INFO: Found associated job
    INFO: Starting 'Oracle Net Configuration Assistant'
    INFO: Starting 'Oracle Net Configuration Assistant'
    INFO: Parsing command line arguments:
    INFO: Parameter "orahome" = /app/oracle/product/11.2.0/db_1
    INFO: Parameter "orahnam" = OraDb11g_home1
    INFO: Parameter "instype" = typical
    INFO: Parameter "inscomp" = client,oraclenet,javavm,server,ano
    INFO: Parameter "insprtcl" = tcp
    INFO: Parameter "cfg" = local
    INFO: Parameter "authadp" = NO_VALUE
    INFO: Parameter "responsefile" = /app/oracle/product/11.2.0/db_1/network/install/netca_typ.rsp
    INFO: Parameter "silent" = true
    INFO: Done parsing command line arguments.
    INFO: Oracle Net Services Configuration:
    INFO: Profile configuration complete.
    INFO: Oracle Net Listener Startup:
    INFO: Running Listener Control:
    INFO: /app/oracle/product/11.2.0/db_1/bin/lsnrctl start LISTENER
    INFO: Listener Control complete.
    INFO: Listener start failed.
    INFO: Check the trace file for details: /app/oracle/cfgtoollogs/netca/trace_OraDb11g_home1-1207155PM0116.log
    INFO: Oracle Net Services configuration failed. The exit code is 1
    INFO:
    WARNING:
    INFO: Completed Plugin named: Oracle Net Configuration Assistant

    Edited by: keymoo on 15-Jul-2012 09:09

    Edited by: keymoo on 15-Jul-2012 09:10
  • 947157
    947157 Member Posts: 33
    Here's the trace log mentioned too


    [[email protected] ~]# tail -50 /app/oracle/cfgtoollogs/netca/trace_OraDb11g_home1-1207155PM0116.log
    [main] [ 2012-07-15 17:01:20.746 BST ] [RuntimeExec.runCommand:77] /bin/sh
    [main] [ 2012-07-15 17:01:20.746 BST ] [RuntimeExec.runCommand:77] -c
    [main] [ 2012-07-15 17:01:20.747 BST ] [RuntimeExec.runCommand:77] /app/oracle/product/11.2.0/db_1/srvm/admin/getcrshome
    [Thread-4] [ 2012-07-15 17:01:20.751 BST ] [StreamReader.run:61] In StreamReader.run
    [main] [ 2012-07-15 17:01:20.752 BST ] [RuntimeExec.runCommand:142] runCommand: Waiting for the process
    [Thread-3] [ 2012-07-15 17:01:20.752 BST ] [StreamReader.run:61] In StreamReader.run
    [main] [ 2012-07-15 17:01:20.764 BST ] [RuntimeExec.runCommand:144] runCommand: process returns 1
    [main] [ 2012-07-15 17:01:20.765 BST ] [RuntimeExec.runCommand:161] RunTimeExec: output>
    [main] [ 2012-07-15 17:01:20.765 BST ] [RuntimeExec.runCommand:170] RunTimeExec: error>
    [main] [ 2012-07-15 17:01:20.765 BST ] [RuntimeExec.runCommand:192] Returning from RunTimeExec.runCommand
    [main] [ 2012-07-15 17:01:20.766 BST ] [CmdToolUtil.doexecute:372] nativeSystem.runRemoteExecCmd failed. Command = /app/oracle/product/11.2.0/db_1/srvm/admin/getcrshome arguments = [] env = null
    [main] [ 2012-07-15 17:01:20.767 BST ] [HAUtils.isHASConfigured:349] Ignoring exception in isHASConfigured: PRCT-1011 : Failed to run "getcrshome"
    [main] [ 2012-07-15 17:01:20.767 BST ] [HAUtils.isHASConfigured:350] oracle.cluster.deployment.ClusterwareInfo.getConfiguredCRSHome(ClusterwareInfo.java:423)
    oracle.sysman.assistants.util.hasi.HAUtils.getCRSHome(HAUtils.java:544)
    oracle.sysman.assistants.util.hasi.HAUtils.getHASHome(HAUtils.java:604)
    oracle.sysman.assistants.util.hasi.HAUtils.isHASConfigured(HAUtils.java:345)
    oracle.net.ca.ConfigureListener.isHASConfigured(ConfigureListener.java:1428)
    oracle.net.ca.ConfigureListener.isHASRunning(ConfigureListener.java:1450)
    oracle.net.ca.ConfigureListener.validateListenerName(ConfigureListener.java:1697)
    oracle.net.ca.ConfigureListener.typicalConfigure(ConfigureListener.java:169)
    oracle.net.ca.SilentConfigure.performSilentConfigure(SilentConfigure.java:185)
    oracle.net.ca.InitialSetup.<init>(NetCA.java:4159)
    oracle.net.ca.NetCA.main(NetCA.java:405)
    [main] [ 2012-07-15 17:01:20.771 BST ] [ConfigureListener.isHASConfigured:1436] Is Oracle Restart configured: false
    [main] [ 2012-07-15 17:01:20.772 BST ] [ConfigureListener.isHASRunning:1465] Is Oracle Restart running: false
    [main] [ 2012-07-15 17:01:20.772 BST ] [ConfigureListener.typicalConfigure:201] Checking for free port in range: 1521-1540
    [main] [ 2012-07-15 17:01:20.773 BST ] [ConfigureListener.isPortFree:1010] Checking if port 1521 is free on local machine...
    [main] [ 2012-07-15 17:01:20.777 BST ] [ConfigureListener.isPortFree:1023] InetAddress.getByName(127.0.0.1): /127.0.0.1
    [main] [ 2012-07-15 17:01:20.777 BST ] [ConfigureListener.isPortFree:1025] Local host IP address: nitrogen.localdomain/10.0.0.7
    [main] [ 2012-07-15 17:01:20.779 BST ] [ConfigureListener.isPortFree:1027] Local host name: nitrogen.localdomain
    [main] [ 2012-07-15 17:01:20.779 BST ] [ConfigureListener.isPortFree:1039] Creating ServerSocket on Port:1521, IP Address: nitrogen.localdomain/10.0.0.7
    [main] [ 2012-07-15 17:01:20.781 BST ] [ConfigureListener.isPortFree:1042] Created ServerSocket successfully.
    [main] [ 2012-07-15 17:01:20.782 BST ] [ConfigureListener.isPortFree:1055] Creating ServerSocket on Port:1521, Local IP Address: /127.0.0.1
    [main] [ 2012-07-15 17:01:20.782 BST ] [ConfigureListener.isPortFree:1059] Created ServerSocket successfully.
    [main] [ 2012-07-15 17:01:20.782 BST ] [ConfigureListener.isPortFree:1065] Creating ServerSocket on Port:1521
    [main] [ 2012-07-15 17:01:20.782 BST ] [ConfigureListener.isPortFree:1068] Created ServerSocket successfully.
    [main] [ 2012-07-15 17:01:20.783 BST ] [ConfigureListener.isPortFree:1088] Returning is Port 1521 free: true
    [main] [ 2012-07-15 17:01:20.783 BST ] [ConfigureListener.typicalConfigure:208] Using port: 1521
    [main] [ 2012-07-15 17:01:20.789 BST ] [ConfigureListener.setListenerParam:1779] Setting ADR_BASE_LISTENER: /app/oracle
    [main] [ 2012-07-15 17:01:20.791 BST ] [ConfigureListener.isPortFree:1010] Checking if port 1521 is free on local machine...
    [main] [ 2012-07-15 17:01:20.791 BST ] [ConfigureListener.isPortFree:1023] InetAddress.getByName(127.0.0.1): /127.0.0.1
    [main] [ 2012-07-15 17:01:20.791 BST ] [ConfigureListener.isPortFree:1025] Local host IP address: nitrogen.localdomain/10.0.0.7
    [main] [ 2012-07-15 17:01:20.792 BST ] [ConfigureListener.isPortFree:1027] Local host name: nitrogen.localdomain
    [main] [ 2012-07-15 17:01:20.792 BST ] [ConfigureListener.isPortFree:1039] Creating ServerSocket on Port:1521, IP Address: nitrogen.localdomain/10.0.0.7
    [main] [ 2012-07-15 17:01:20.792 BST ] [ConfigureListener.isPortFree:1042] Created ServerSocket successfully.
    [main] [ 2012-07-15 17:01:20.792 BST ] [ConfigureListener.isPortFree:1055] Creating ServerSocket on Port:1521, Local IP Address: /127.0.0.1
    [main] [ 2012-07-15 17:01:20.793 BST ] [ConfigureListener.isPortFree:1059] Created ServerSocket successfully.
    [main] [ 2012-07-15 17:01:20.793 BST ] [ConfigureListener.isPortFree:1065] Creating ServerSocket on Port:1521
    [main] [ 2012-07-15 17:01:20.793 BST ] [ConfigureListener.isPortFree:1068] Created ServerSocket successfully.
    [main] [ 2012-07-15 17:01:20.794 BST ] [ConfigureListener.isPortFree:1088] Returning is Port 1521 free: true
  • 947157
    947157 Member Posts: 33
    I clicked retry, and the installer carried on. At the end I see this:
    http://i.imgur.com/CxIVz.png

    Here's the emConfig.log

    [[email protected] ~]# tail -50 /app/oracle/cfgtoollogs/dbca/nitro/emConfig.log
    CONFIG: Host having instnces running for database nitro : ol5-112.localdomain
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.ParamsManager setParam
    CONFIG: Setting param: REP_DB_RUNNING_HOST value: ol5-112.localdomain
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.ParamsManager getRepDbPort
    CONFIG: Listener Port: 1521
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil isLocalConnectionRequired
    CONFIG: isLocalConnectionRequired: true
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
    CONFIG: isLocalConnectionRequired: true. Connecting to database instance locally.
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineLoacly
    CONFIG: SQLEngine connecting with SID: nitro, oracleHome: /app/oracle/product/11.2.0/db_1, and user: SYSMAN
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineLoacly
    CONFIG: SQLEngine created successfully and connected
    Jul 15, 2012 6:31:49 PM oracle.sysman.emcp.ParamsManager checkListenerStatusForDBControl
    CONFIG: ORA-12170: TNS:Connect timeout occurred

    oracle.sysman.assistants.util.sqlEngine.SQLFatalErrorException: ORA-12170: TNS:Connect timeout occurred

    at oracle.sysman.assistants.util.sqlEngine.SQLEngine.executeImpl(SQLEngine.java:1650)
    at oracle.sysman.assistants.util.sqlEngine.SQLEngine.executeSql(SQLEngine.java:1898)
    at oracle.sysman.emcp.ParamsManager.checkListenerStatusForDBControl(ParamsManager.java:3230)
    at oracle.sysman.emcp.EMReposConfig.unlockMGMTAccount(EMReposConfig.java:1000)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:345)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:157)
    at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:253)
    at oracle.sysman.assistants.util.em.EMConfiguration.run(EMConfiguration.java:583)
    at oracle.sysman.assistants.dbca.backend.PostDBCreationStep.executeImpl(PostDBCreationStep.java:931)
    at oracle.sysman.assistants.util.step.BasicStep.execute(BasicStep.java:210)
    at oracle.sysman.assistants.util.step.Step.execute(Step.java:140)
    at oracle.sysman.assistants.util.step.StepContext$ModeRunner.run(StepContext.java:2667)
    at java.lang.Thread.run(Thread.java:595)
    Jul 15, 2012 6:31:49 PM oracle.sysman.emcp.EMConfig perform
    SEVERE: Listener is not up or database service is not registered with it. Start the Listener and register database service and run EM Configuration Assistant again .
    Refer to the log file at /app/oracle/cfgtoollogs/dbca/nitro/emConfig.log for more details.
    Jul 15, 2012 6:31:49 PM oracle.sysman.emcp.EMConfig perform
    CONFIG: Stack Trace:
    oracle.sysman.emcp.exception.EMConfigException: Listener is not up or database service is not registered with it. Start the Listener and register database service and run EM Configuration Assistant again .
    at oracle.sysman.emcp.ParamsManager.checkListenerStatusForDBControl(ParamsManager.java:3245)
    at oracle.sysman.emcp.EMReposConfig.unlockMGMTAccount(EMReposConfig.java:1000)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:345)
    at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:157)
    at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:253)
    at oracle.sysman.assistants.util.em.EMConfiguration.run(EMConfiguration.java:583)
    at oracle.sysman.assistants.dbca.backend.PostDBCreationStep.executeImpl(PostDBCreationStep.java:931)
    at oracle.sysman.assistants.util.step.BasicStep.execute(BasicStep.java:210)
    at oracle.sysman.assistants.util.step.Step.execute(Step.java:140)
    at oracle.sysman.assistants.util.step.StepContext$ModeRunner.run(StepContext.java:2667)
    at java.lang.Thread.run(Thread.java:595)
    Jul 15, 2012 6:31:49 PM oracle.sysman.emcp.EMConfig restoreOuiLoc
    CONFIG: Restoring oracle.installer.oui_loc to /app/oracle/product/11.2.0/db_1/oui
  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond
    keymoo wrote:
    I clicked retry, and the installer carried on. At the end I see this:
    http://i.imgur.com/CxIVz.png

    Here's the emConfig.log

    [[email protected] ~]# tail -50 /app/oracle/cfgtoollogs/dbca/nitro/emConfig.log
    CONFIG: Host having instnces running for database nitro : ol5-112.localdomain
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.ParamsManager setParam
    CONFIG: Setting param: REP_DB_RUNNING_HOST value: ol5-112.localdomain
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.ParamsManager getRepDbPort
    CONFIG: Listener Port: 1521
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil isLocalConnectionRequired
    CONFIG: isLocalConnectionRequired: true
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
    CONFIG: isLocalConnectionRequired: true. Connecting to database instance locally.
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineLoacly
    CONFIG: SQLEngine connecting with SID: nitro, oracleHome: /app/oracle/product/11.2.0/db_1, and user: SYSMAN
    Jul 15, 2012 6:31:28 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngineLoacly
    CONFIG: SQLEngine created successfully and connected
    Jul 15, 2012 6:31:49 PM oracle.sysman.emcp.ParamsManager checkListenerStatusForDBControl
    CONFIG: ORA-12170: TNS:Connect timeout occurred
    oracle.sysman.assistants.util.sqlEngine.SQLFatalErrorException: ORA-12170: TNS:Connect
    timeout occurred


    most common cause is a Firewall on or between client & DB Server.
    [email protected]:~$ sudo iptables --list
    [sudo] password for bcm: 
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    [email protected]:~$ 
This discussion has been closed.