Forum Stats

  • 3,733,246 Users
  • 2,246,737 Discussions
  • 7,856,631 Comments

Discussions

Local Connection Creation Problem

969661
969661 Member Posts: 1
edited November 2012 in SQL Developer
I want to create a local connection, but it failed. It didn't appear any related dialog box after I click "Create Local Connections", it just remain same. Then, I try to use another way to create local connection by choosing "Local/Bequeath" for Connection Type via "New/Select Database Connection". However, it shown me "Status : Failure-Test failed: Incompatible version of libocijdbc[Jdbc:112030, Jdbc-OCI:112020" when I test the connection.
Now I really confuse and don't know how to solve the problem.

Software: Oracle SQL Developer (3.2.09)
Build MAIN: 09.30
Java(TM) Platform: 1.6.0_35

I help anyone can solve my problem, thanks.

Tan

Answers

  • Gary Graham-Oracle
    Gary Graham-Oracle Member Posts: 3,256 Bronze Crown
    Hi Tan,

    The fact that Create Local Connections did nothing probably indicates you have no local database(s) on you computer available to connect to. If you have no local database installed, you can...

    1. Somehow get the connection details for a remote database.
    2. Install a local DB. Oracle Express Edition 11g R2 is free.
    http://www.oracle.com/technetwork/products/express-edition/downloads/index.html
    Once you have database to access, either local or remote, you can try creating a basic connection. For example, if you have a local express edition installed:
    Connection Type: Basic
    Connection Name: system_xe
    User: system
    Password: <the password you chose when you installed XE>
    Host: localhost
    Port: 1521
    SID: xe
    Hope this helps,
    Gary
  • 972556
    972556 Member Posts: 1
    In Connections right click mouse and select - Create Local Connections, you can get every users in the folder : Auto-gereated local Connections:
    / as sysdba
    ANONMOUS
    SYSTEM
    system_xe
    ...

    SYSTEM and system_xe password is the one you put it in while setup.
    / as sysdba is the one with error when you try to open it:
    Incompatible version of libocijdbc[Jdbc:112030, Jdbc-OCI:112020

    This is version 3.2.20.9
This discussion has been closed.