On January 27th, this site will be read-only as we migrate to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,632 Users
  • 2,269,769 Discussions
  • 7,916,800 Comments

Discussions

non-secure OS, can't install new versions [ This version is excluded ]

madmax007
madmax007 Member Posts: 6
edited Oct 31, 2012 12:12PM in PHP
I had apache2 enabled in a zone and installed php52 on top of it. this worked well ast week.

Then someone needed php53, so i deinstalled php-52 and accompying products.

I tried to install php-53 but it complained about a blocked reference

Creating Plan /
pkg install: No matching version of web/php-53 can be installed:
Reject: pkg://solaris/web/[email protected],5.11-0.175.1.0.0.24.0:20120904T174930Z
Reason: All versions matching 'require' dependency pkg:/system/[email protected],5.11-0.175.1.0.0.23.0 are rejected
Reject: pkg://solaris/system/[email protected],5.11-0.175.1.0.0.24.2:20120919T185204Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/[email protected],5.11-0.175.0.12.0.4.1:20121002T155703Z

At first i thought i needed to update the Solaris 11 core, so i updated all the OS. I rebooted and tried again, but the same error persists.

I searched for the error and found little info about it. someone mentions that you need a support contract, but WE DO HAVE A CONTRACT!

I tried to get back to php-52, but now also apache-php52 package complains about this so i'm lost completely.

Does anyone know how to solve this?

Answers

  • Christopher Jones-Oracle
    Christopher Jones-Oracle Member Posts: 1,657 Employee
    I'll ask a Solaris person to look at this post.

    Since you have a support contract you could alternatively log a Service Request. Let us know if you do this.
  • Hello.

    You're mixing versions of the OS which won't work.

    Reject: pkg://solaris/web/[email protected],5.11-0.175.1.0.0.24.0

    175.1 indicates Solaris 11.1.

    Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/[email protected],5.11-0.175.0.12.0.4.1

    175.0 indicates Solaris 11.

    You need to update the OS to Solaris 11.1.

    Give this a read:
    http://www.oracle.com/technetwork/articles/servers-storage-admin/howto-update-11dot1-ips-1866781.html

    BTW, you can have both php-52 and php-53 installed at the same time
    then select which one runs under Apache.

    $ man php

    should help you there.

    If not then come back and we'll get this sorted.
This discussion has been closed.