Forum Stats

  • 3,784,366 Users
  • 2,254,929 Discussions
  • 7,880,792 Comments

Discussions

try to call wfs.exe (MS fax and scan) with webutil_host !!

alinzenb
alinzenb Member Posts: 138
edited Nov 15, 2012 4:25AM in Forms
hi,


I would call from Forms the MS scan and fax application “wfs.exe”.
This is found under windows\system32.

call:
WEBUTIL_HOST.NONBLOCKING ('cmd /c C:\windows\system32\wfs.exe');

Unfortunately, nothing happens. No error message and no cmd-process remains open in the taskmanager.
with other applications it works. For example:

WEBUTIL_HOST.BLOCKING('cmd /c C:\Windows\System32\notepad.exe');
WEBUTIL_HOST.BLOCKING('cmd /c C:\Windows\System32\calc.exe');

I use Forms 10.1.2.3 on Windows 7.

Does anyone have any idea or can test that if it works?

thx Alfred

Answers

  • vansul
    vansul Member Posts: 438
    you can use
    WEBUTIL.client_HOST ('cmd /c C:\windows\system32\wfs.exe',hide_screen);
    instead of
    WEBUTIL_HOST.NONBLOCKING ('cmd /c C:\windows\system32\wfs.exe');


    which will run the wfs.exe file located in the windows\system32 directory. if client machine is on the windows O/S
    you can view the process list by tasklist command on the command prompt.

    you can use cmd /k option for remaining in that session for the errorlevel checking.
    vansul
  • alinzenb
    alinzenb Member Posts: 138
    i have found the problem on windows 64 bit

    if i call the cmd /k command from Forms i just see an cmd *32 Bit
    it is not posible to open the cmd 64 bit version
    why ???


    if i call from Commandline
    64:bit
    C:\Windows\system32\cmd /k C:\Windows\system32\wfs.exe works because opens cmd 64 bit Version

    32 bit
    C:\Windows\SysWOW64\cmd /k C:\Windows\system32\wfs.exe not work because opens cmd 32 bit Version


    ????
  • alinzenb
    alinzenb Member Posts: 138
    i have finde the solution
    use “virtual folder” called \Windows\sysnative

    WEBUTIL_HOST.NONBLOCKING('cmd /c %windir%\sysnative\wfs.exe');
    it works ;-)

    Alfred
This discussion has been closed.