Forum Stats

  • 3,768,925 Users
  • 2,252,875 Discussions
  • 7,874,802 Comments

Discussions

Unable to install APEX packaged application to user's default schema

user6057328
user6057328 Member Posts: 1
edited Oct 15, 2013 9:38PM in Packaged Applications

Got 2 schemas in my workspace, AABB and APEX_DEMO. I've created a separate user, DemoAdmin with default to only APEX_DEMO, to install APEX packaged applications there.  However, when logged in as DemoAdmin, and trying to install any package, it always tries to use AABB, actually the first schema created in the workspace. Is this a bug, or is that supposedly the behavior?  Thanks for the inputs!!

Answers

  • ittichai
    ittichai Member Posts: 278
    edited Oct 15, 2013 9:51PM

    When you tried to install a packaged application, which schema it said it will install to? The message should be displayed right before "Install Application".


    I tried to install the packaged application myself using an APEX account which has the SCHEMA2 as default. It still chose the SCHEMA1 by default. My take here is that this seems to be a limitation.

    Meeting Minutes
    Application Express Accounts
    WORKSPACE1
    SCHEMA1

    To work-around this, I install the packaged applications from the download files (fxxxx.sql) which can be found under APEX installation files (Downloads\apex_4.2.2_en\apex\core\packaged_apps). (Make sure choose the one compatible with your APEX version.) Just install it as you import an application file. During the import, you will have an option to choose which schema to import to (under Parsing Schema drop-down list).

    Hope it helps.

    Ittichai

This discussion has been closed.