Forum Stats

  • 3,816,078 Users
  • 2,259,137 Discussions
  • 7,893,388 Comments

Discussions

SQL Developer 3.2.20.09.87 for Mac OSX won't start

1050607
1050607 Member Posts: 4
edited Nov 18, 2013 3:15PM in SQL Developer

Hello Guys,

hope this is the right place to question this:

Yesterday I updated my OSX to Mavericks an today I am trying to get started with Oracle  SQL Developer 3.2.20.09.87 i downloaded for Mac.

I've already installed Java JDK 1.7.0_21.

When is unzip the .gz file in a Folder and try to start the SQLDeveloper.app file the Icon only Jumps up and down in my Dock and nothing happens. After a while i stops to jump and nothing more happens.

Does anyone have an idea what could be the problem with it?

Could it be the Version of the JDK oder even the Maverick OSX?

I'm looking forward to your answers

Marco

10516992605861user2411528

Answers

  • 1050607
    1050607 Member Posts: 4

    Hi guys,

    just solved the problem myself.

    Here's the solution:

    With Mavericks the locations of java just changed and when you start the app it is just looking and not finding java.

    So right click on the sql developer app an click show package content.

    Then navigate to /Contents/Resources/sqldeveloper/sqldeveloper/bin/ and start the sqldeveloper file in the terminal.

    It will now ask you for the location. Just type in "/usr" and it will start automaticly.

    For the future you can launch it via app-icon.

    Marco

    1051699user2411528
  • user12213642
    user12213642 Member Posts: 1
    edited Oct 28, 2013 9:56AM

    Another fix is simply to install an older version of Java (as I needed to for other development purposes). The JDK 6 installer still drops it in the old location, and so SQL Developer can run fine off of that.

    That said, I like your fix better, as it works for non-legacy JDK users.

  • 1051699
    1051699 Member Posts: 1

    Hi,

    Thanks for the solution,i struggled with this issue for several times and your solution solved it for me but unfortunately it doesn't launch automatically after changing the java location inside the terminal.Everytime I launch the sqldeveloper,I have to go inside the package and execute through the binary file.

    Any idea on that?

    I don't want to install older version of java since I'm also working on Eclipse and need the jdk7 actively.

    Thanks a lot again!

  • 1052862
    1052862 Member Posts: 1
    edited Nov 6, 2013 9:52AM

    Thank you for solution!

    On my system, SQL Developer keeps writing to its log file, until it fills all available disk space, that leeds to system freeze...

  • Hi,

    Thanks to Marco, launching sqldeveloper.sh from the command line works, and launching from the App icon gets the bash script into an infinite loop.

    In my case, running sqldeveloper.sh from the command line did not prompt me for the java home because it found it via my JAVA_HOME environment variable.  However, running from the App icon fails to find it.  This leads me to think that JAVA_HOME is not set at the system level. 

    I Googled a bit, and tried to figure out how to set environment variables at the system level for the OS X apps.

    http://stackoverflow.com/questions/135688/setting-environment-variables-in-os-x

    but decided to just hack the sqldeveloper.sh script and call it a day.  I added an 'export JAVA_HOME' statement in sqldeveloper.sh and the file now looks like this

    #!/bin/bash

    here="${0%/*}"

    cd "${here}"

    #adding this so OSX will prompt to install java if missing

    export JAVA_HOME=/Library/Java/JavaVirtualMachines/1.6.0_37-b06-434.jdk/Contents/Home/

    java -version

    cd ../Resources/sqldeveloper/sqldeveloper/bin

    bash ./sqldeveloper >/tmp/sqldeveloper-startup-`uuidgen`.log

    That was enough to launch from the app icon.

  • In the original solution the shell lies to you and doesn't actually create a "~/.sqldeveloper/ jdk" after your type in "/usr".

    To get it to persist create an empty "~/.sqldeveloper/jdk" file before executing sqldeveloper in the terminal. It will then write to the file and you can then open Sql Developer normally.

    Or you could just create the "~/.sqldeveloper/jdk" file and put "/usr" in it and not have to worry traversing the applications contents.

    2605861
  • thatJeffSmith-Oracle
    thatJeffSmith-Oracle Distinguished Product Manager Posts: 8,513 Employee

    The filling up the disk/temp space issue has been addressed for v4, shouldn't happen anymore once we go production.

  • Kris Rice-Oracle
    Kris Rice-Oracle Posts: 1,393 Employee

    Until the next version is posted.  This is easy to fix and I don't recall why I did the > to /tmp.   Just change to /dev/null such as:

    bash ./sqldeveloper >/dev/null

    That's what's in the next drop.


    -kris


  • Marco,

    doing what you proposed I didn't receive any "ask for location" but, after some time, I receive the following messages:

    java.lang.NoClassDefFoundError: oracle/javatools/util/Log

      at oracle.ide.IdeCore.<clinit>(IdeCore.java:2119)

      at oracle.ideimpl.Main.start(Main.java:183)

      at oracle.ideimpl.Main.main(Main.java:146)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:597)

      at oracle.ide.boot.PCLMain.callMain(PCLMain.java:62)

      at oracle.ide.boot.PCLMain.main(PCLMain.java:54)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:597)

      at oracle.classloader.util.MainClass.invoke(MainClass.java:128)

      at oracle.ide.boot.IdeLauncher.bootClassLoadersAndMain(IdeLauncher.java:189)

      at oracle.ide.boot.IdeLauncher.launchImpl(IdeLauncher.java:89)

      at oracle.ide.boot.IdeLauncher.launch(IdeLauncher.java:65)

      at oracle.ide.boot.IdeLauncher.main(IdeLauncher.java:54)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:597)

      at oracle.ide.boot.Launcher.invokeMain(Launcher.java:713)

      at oracle.ide.boot.Launcher.launchImpl(Launcher.java:115)

      at oracle.ide.boot.Launcher.launch(Launcher.java:68)

      at oracle.ide.boot.Launcher.main(Launcher.java:57)

    Caused by: oracle.classloader.util.AnnotatedClassNotFoundException:

        Classe mancante: oracle.javatools.util.Log

      Classe dipendente: oracle.ide.IdeCore

              Loader: ide-global:11.1.1.0.0

          Origine codice: /Applications/SQLDeveloper.app/Contents/Resources/sqldeveloper/ide/extensions/oracle.ide.jar

        Configurazione: boot classpath entry in oracle.ide.boot.PCLMain.BOOT_ENTRIES

    Questo caricamento ? stato iniziato alle ide-global:11.1.1.0.0 utilizzando il metodo loadClass().

    La classe mancante non ? disponibile in nessuna origine codice o loader nel sistema.

      at oracle.classloader.PolicyClassLoader.handleClassNotFound(PolicyClassLoader.java:2190)

      at oracle.classloader.PolicyClassLoader.internalLoadClass(PolicyClassLoader.java:1733)

      at oracle.classloader.PolicyClassLoader.loadClass(PolicyClassLoader.java:1689)

      at oracle.classloader.PolicyClassLoader.loadClass(PolicyClassLoader.java:1674)

      ... 26 more

    Do you know why and how I can solve the problem?

    Enzo

  • I tried your solution,  but still getting

    Process:         java [31120]

    Path:            /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home/bin/java

    Identifier:      net.java.openjdk.cmd

    Version:         1.0 (1.0)

    Code Type:       X86-64 (Native)

    Parent Process:  bash [30830]

    Responsible:     Terminal [12656]

    User ID:         503

    Date/Time:       2013-11-18 12:15:28.073 -0800

    OS Version:      Mac OS X 10.9 (13A603)

    Report Version:  11

    Anonymous UUID:  9241C835-0B42-64C7-AF74-E36CB5D87735

    Sleep/Wake UUID: 073641DB-EB3B-49E8-9EC6-271D17B41925

    Crashed Thread:  28  Java: Java2D Queue Flusher

    Exception Type:  EXC_BAD_ACCESS (SIGABRT)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

    VM Regions Near 0:

    -->

        __TEXT                 0000000104623000-0000000104634000 [   68K] r-x/rwx SM=COW  /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home/bin/java

    Application Specific Information:

    abort() called

This discussion has been closed.