Forum Stats

  • 3,827,258 Users
  • 2,260,753 Discussions
  • 7,897,193 Comments

Discussions

ALERT LOG - ORA-3136 AT 7:01 AM EVERYDAY [WARNING: inbound connection timed out (ORA-3136)]

Ran G
Ran G Member Posts: 49
edited Nov 23, 2013 10:01AM in General Database Discussions

Hello Techies,

Good day to you all.

I have a situation here in my oracle production databse environement. I see ORA-3136 error/warning  every day occuring at the same time( i.e, 7:01AM ) and i do not have any scheduled jobs or tasks at that time.

May be some task which runs on my database trying to connect to DB and fails due to wrong credentials ?  not sure how to find out as i tried to checkc the OS- Win task scheduler and Grid EM for any such tasks/jobs.

Even we have set,  "  INBOUND_CONNECT_TIMEOUT=120 "   in the sqlnet.ora file to avoid inbound connection timeout errors, which we used to get a couple of months back and now we get             ORA-3136 Warnings in the alert log since 10day(s) or more.

Environment- Version:

--------------------------------

OS - WINDOWS 2008R2 64 Bit

Oracle DB - 10G DB, 11G Oracle Grid configured.

Can you plz suggest me ways to trace and findout this.

Regards,

RanG.

2677428
«1

Answers

  • Srini Chavali-Oracle
    Srini Chavali-Oracle Member Posts: 29,596 Employee

    This likely indicates a remote client or database was unable to connect. Pl see the troubleshooting steps in these MOS Docs

    465043.1

    730066.1

    HTH
    Srini

  • sb92075
    sb92075 Member Posts: 42,196 Blue Diamond

    The most common cause is a FireWall on or between client & the DB Server

  • TSharma-Oracle
    TSharma-Oracle Member Posts: 1,900 Silver Trophy
    edited Nov 21, 2013 9:05AM

    What does your SQLNET.LOG file tells you? It should tell you atleast from where the connection is coming from and possible error?

  • Ran G
    Ran G Member Posts: 49

    Hi TSharma,

    Yes, it gave me the connection details, but i have set inboud_connect_timeout=o and reload the listener, but still i see th error?

    Regards,

    RanG

  • Ran G
    Ran G Member Posts: 49

    Hi,

    Can you give me the instructions for the above cause how to deal with?

    Regards,

    RanG

  • Ran G
    Ran G Member Posts: 49

    Hi,

    Yes, i have set inboud_connect_timeout=o and reload the listener, but still i see the error?

    Regards,

    RanG

  • Girish Sharma
    Girish Sharma Member Posts: 4,980 Bronze Crown

    Can you post your listener.ora, sqlnet.ora ?

    Have you enabled sqlnet tracing and can paste sqlnet trace file ?

    How much is Server's RAM and configurations ?

    Are there any ORA-0600 and/or ORA-7445 in the alert log too ?

    Can you post output of below command :

    SELECT NAME, BYTES

    FROM v$sgainfo;

    Regards

    Girish Sharma

  • Ran G
    Ran G Member Posts: 49

    Hi,

    No ORA-0600 and/or ORA-7445 in the alert log ..,

    SQLNET LOG:

    ---------------------

    SQLNET.AUTHENTICATION_SERVICES= (NTS)


    NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)

    # add line to avoid ORA-3135 message
    INBOUND_CONNECT_TIMEOUT=0

    SQLNET.INBOUND_CONNECT_TIMEOUT=0

    SQL> SELECT NAME, BYTES from v$sgainfo;

    NAME                                  BYTES
    -------------------------------- ----------
    Fixed SGA Size                      2075368
    Redo Buffers                       14700544
    Buffer Cache Size                2382364672
    Shared Pool Size                 3640655872
    Large Pool Size                    16777216
    Java Pool Size                     16777216
    Streams Pool Size                  16777216
    Granule Size                       16777216
    Maximum SGA Size                 6442450944
    Startup overhead in Shared Pool   100663296
    Free SGA Memory Available         352321536

    11 rows selected.

    Regards,

    RanG

  • Girish Sharma
    Girish Sharma Member Posts: 4,980 Bronze Crown

    I don't know how your listener.ora looks like (even though I have asked in my earlier reply), but you can trace the connect request by enabling listener trace with adding below lines in listener.ora :

    TRACE_LEVEL_LISTENER=16 
    TRACE_FILE_LISTENER=listener.trc (listener.trc is the default) 
    TRACE_DIRECTORY_LISTENER=$ORACLE_HOME/network/trace 
    

    NOTE: 'LISTENER' is actually the name of the listener in the above example. It may be different on your system. View/ edit your listener.ora file to get the names of the defined listeners. Source:SQL*Net FAQ - Oracle FAQ

    Regards

    Girish Sharma

This discussion has been closed.