Forum Stats

  • 3,838,917 Users
  • 2,262,415 Discussions
  • 7,900,802 Comments

Discussions

Connection refused when attempting to contact 127.0.0.1:8080

464611
464611 Member Posts: 7
Hello,
I have problem with this new oracle server
Operating system: Windows XP SP 2
Oracle version: Oracle Database 10g Express Edition Beta Release for Microsoft Windows

I finish the installation and I start the server:
D:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleMTSRecoveryServ
ice
The OracleMTSRecoveryService service is starting.
The OracleMTSRecoveryService service was started successfully.
D:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleXETNSListener
The OracleXETNSListener service is starting.
The OracleXETNSListener service was started successfully.
D:\oraclexe\app\oracle\product\10.2.0\server\BIN>net start OracleServiceXE
The OracleServiceXE service is starting.
The OracleServiceXE service was started successfully.

And if I try to connect with admin panel (http://127.0.0.1:8080/htmldb) via browser, I get "connection refused when attempting to contact 127.0.0.1:8080".
I disabled firewall and same thing.
I installed oracle into another computer and nothing new.
My friend tried it on his windows XP and the same thing :(
«134

Comments

  • Hans Forbrich
    Hans Forbrich Member Posts: 11,543 Gold Trophy
    Pull up a command/DOS box and enter 'ipconfig'. It should give you an IP address with the form of 127.0.0.1 for your current connection. Try using that instead of 127.0.0.1
  • 465063
    465063 Member Posts: 17
    Hi,

    On my windows XP SP2 machine I also have a service called OracleXEClrAgent
    you could start this one with:
    net start OracleXEClrAgent

    the homepage of the database works fine on that machine

    Emiel
  • 465063
    465063 Member Posts: 17
    You can als use the following option after you started the Oracle database.
    go to start
    -->all programs
    -->Oracle Database 10g Expres Edition
    -->Go to Database Homepage

    on my Windows machine the URL looks like http://127.0.0.1:8080/htmldb/f?p=4550:11:17293100987261901207::NO:::

    Emiel
  • 241066
    241066 Member Posts: 776
    Couple of things to try
    From the command line windows, see if you can ping 127.0.0.1
    If you get an error message then you have something wrong in your machine setup that you need to fix

    If you can ping 127.0.0.1 then check that your browser is not blocking the connections. One thing we have seen is that sometimes people have No Proxies set for localhost and 127.0.0.1, and they will have an invalid character after the 1, such as a . (period)
  • 441385
    441385 Member Posts: 4
    First see if OracleServiceXE and OracleXETNSListener services are running.

    Replace 127.0.0.1 in the url, with the IP or the name of your machine. It must match the host declared in the tnsnames.ora file. The path is \oraclexe\app\oracle\product\10.2.0\server\admin\network\admin

    OracleClrAgent service seems to be used when you want to run .net procedure from the database.

    Reynaldo
  • 464611
    464611 Member Posts: 7
    edited Nov 4, 2005 11:58AM
    I have this in my tnsnames.ora file:
    XE =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = test)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = XE)
    )
    )

    I can ping 127.0.0.1. I tried to connect with http://test:8080, I got same error.
    I tried http://test:1521 it doesn't do nothing, I don't get error and browser doesn't load anything :)

    Message was edited by:
    Agur
  • tkyte-Oracle
    tkyte-Oracle Member Posts: 339
    your hostname is "test"?

    can you ping test?
  • 464611
    464611 Member Posts: 7
    Yes, my hostname is test and I can ping it too :)
  • 464611
    464611 Member Posts: 7
    Yeah.
    I found solution to my problem. I am living in Estonia so I had set Language for non-Unicode programs (Control Panel>Regional and language options>Advanced) to Estonian. I changed it to English(United States) and reinstalled the Oracle and now it works :)
  • Also note the following:
    You can always run the "netstat -an" command from the command prompt to see if a port is actually listening on your server.
    Nice to see you got it working.
This discussion has been closed.