Forum Stats

  • 3,853,517 Users
  • 2,264,230 Discussions
  • 7,905,376 Comments

Discussions

Unable to connect to URL: http://VTPL-L-016:8888/PricingApp-PricingProject-context-root/CustomPriceW

Hi,

    I have created Webservice and deployed on OC4J using jdeveloper (10.1.3.0.4). When i call my method in test class, I getting the following error.

WARNING: Unable to connect to URL: http://VTPL-L-016:8888/PricingApp-PricingProject-context-root/CustomPriceWebServiceSoapHttpPort due to java.security.PrivilegedActionException: javax.xml.soap.SOAPException: Message send failed: Connection refused: connect

Source breakpoint occurred at line 93 of CustomPriceWebServiceSoapHttp_Stub.java.

java.rmi.RemoteException: ; nested exception is:

  HTTP transport error: javax.xml.soap.SOAPException: java.security.PrivilegedActionException: javax.xml.soap.SOAPException: Message send failed: Connection refused: connect

  at pricingproject.proxy.runtime.CustomPriceWebServiceSoapHttp_Stub.priceInquiry(CustomPriceWebServiceSoapHttp_Stub.java:93)

  at pricingproject.PricingTest.main(PricingTest.java:15)

Caused by: HTTP transport error: javax.xml.soap.SOAPException: java.security.PrivilegedActionException: javax.xml.soap.SOAPException: Message send failed: Connection refused: connect

  at oracle.j2ee.ws.common.util.exception.JAXRPCExceptionBase.<init>(JAXRPCExceptionBase.java:93)

  at oracle.j2ee.ws.common.util.exception.JAXRPCExceptionBase.<init>(JAXRPCExceptionBase.java:88)

  at oracle.j2ee.ws.client.ClientTransportException.<init>(ClientTransportException.java:32)

  at oracle.j2ee.ws.client.http.HttpClientTransport.invokeImpl(HttpClientTransport.java:144)

  at oracle.j2ee.ws.client.http.HttpClientTransport.invoke(HttpClientTransport.java:120)

  at oracle.j2ee.ws.client.StreamingSender._sendImpl(StreamingSender.java:169)

  at oracle.j2ee.ws.client.StreamingSender._send(StreamingSender.java:110)

  at pricingproject.proxy.runtime.CustomPriceWebServiceSoapHttp_Stub.priceInquiry(CustomPriceWebServiceSoapHttp_Stub.java:77)

  ... 1 more

Process exited.

But When I copy the same URL in brower and I am able to see the webservice.

Can anyone please suggest on this.

Thanks,

Chaitanya

Tagged:
This discussion has been closed.