Forum Stats

  • 3,740,524 Users
  • 2,248,268 Discussions
  • 7,861,308 Comments

Discussions

Error installing Java JRE > 1.7.51

user6439156
user6439156 Member Posts: 3

Hello all,

I have some troubles installing Java JRE on Windows 8.1 x64 (latest updates installed).

Incedent scenario:

OS: Windows 8.1 x64 german in windows domain (clean/fresh installation from USB stick without any other programs installed)

following installations worked without any problems (install user is domain admin):

jre-7u21-windows-i586.exe

jre-7u21-windows-x64.exe

jre-7u40-windows-i586.exe

jre-7u40-windows-x64.exe

jre-7u45-windows-i586.exe

jre-7u45-windows-x64.exe

jre-7u51-windows-i586.exe

jre-7u51-windows-x68.exe

and these installations dosn't working:

jre-7u55-windows-i586.exe

jre-7u55-windows-x64.exe

jre-7u60-windows-i586.exe

jre-7u60-windows-x68.exe

java_install_reg.log:

** Executing the following command: **

"C:\Program Files\Java\jre7\bin\javaw.exe"  -Xshare:dump

-- Running RegisterDeploy(TRUE, szJavaHome)

RegisterDeploy returned: 6

-- Exec: RegisterDeploy(TRUE, szJavaHome) failed.

msi installer log (/l*v):

MSI (s) (BC:98) [15:48:37:272]: Executing op: ActionStart(Name=InstallJava,Description=Java Runtime Environment wird registriert,)

Aktion : InstallJava. Java Runtime Environment wird registriert

MSI (s) (BC:98) [15:48:37:319]: Executing op: CustomActionSchedule(Action=InstallJava,ActionType=3073,Source=BinaryData,Target=MSIInstallJRE,)

MSI (s) (BC:98) [15:48:37:335]: Creating MSIHANDLE (2) of type 790536 for thread 2712

MSI (s) (BC:88) [15:48:37:350]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIA98B.tmp, Entrypoint: MSIInstallJRE

MSI (s) (BC:9C) [15:48:37:366]: Generating random cookie.

MSI (s) (BC:9C) [15:48:37:397]: Created Custom Action Server with PID 252 (0xFC).

MSI (s) (BC:C4) [15:48:37:429]: Running as a service.

MSI (s) (BC:C4) [15:48:37:460]: Hello, I'm your 64bit Elevated custom action server.

CustomAction InstallJava returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

MSI (s) (BC:88) [15:48:49:311]: Closing MSIHANDLE (2) of type 790536 for thread 2712

Aktion beendet : InstallFinalize. Rückgabewert 3.

And now the mysterium:

If I remove the computer from the domain and install the 7u55 or 7u60 (as local admin) both installs without any problems.

please help,

any suggestions

27437282bf4e5d9-980d-477d-bd7c-9bf730f723d12709705

Answers

  • 2709705
    2709705 Member Posts: 4
    edited Jul 9, 2014 8:37AM

    Similarly, in the Russian version Windows 8.1.

    After join to the domain, jre7u55, jre7u60, jre8, jre8u5 not installed.

    There is a temporary solution:

    1. Install English Lang Pack

    2. Apply English for Display language and Copy settings to Welcome screen and system accounts

    http://nexus.orel.ru/1.png

    3. Return the old language, and copy settings to New user accounts

    4. jre7u55, jre7u60, jre8, jre8u5  install successfully.

  • 2709705
    2709705 Member Posts: 4

    This problem not fixed in jre7u65/8u11.

  • 2727771
    2727771 Member Posts: 4
    edited Aug 6, 2014 3:06PM

    We also have this problem on many machines. Have you found any solution without editing language? Java 7 Update 67 did not fix the problem. We have Norwegian language.

    Bjørn Erik

  • 2727771
    2727771 Member Posts: 4

    That is good. I can't understand why this bug get priority 3. It should have been priority 1 if you ask me. We have over 8000 computers where java install fails, so we have to run on Java 7 Update 51 unntil this is resolved. Is there anyone in Oracle who can say anything aboute the fixtime for this issue? It is critical.

    Regards
    Bjørn Erik

    2743728
  • 2743728
    2743728 Member Posts: 1
    edited Sep 2, 2014 3:29AM

    We have the same issue with German Windows 8.1. Changing the language is not an option. This bug is reported since July 14 and still no fix. Trying to update to Java Runtime Environment 8.0 build 20 (64-bit) is failing too. Oracle may should start fixing there bugs instead of joining with ASK. => Oracle is now the ASK Company.......

  • 2727771
    2727771 Member Posts: 4

    So now this bug is closed as incomplete because they could not reproduce it. I have a way to reproduce it. If you have all that is known here, Norwegian/Russian/German or any other localized Windows 8/8.1 and joined to a domain. Then download Java 7 Update 55 or newer version, exe or msi, and then disconnect network before installing. Then you will get this error every time. I really hope someone in Oracle can see this and give the consultant working with this BUG this information. For us this BUG is very critical.

    Bjørn Erik

  • shruda
    shruda Member Posts: 16

    Hi,

    I have the same problem on two German windows 8.1 machines! I'm able to install the JDK but not the contained or separate JRE -> tested with JRE 7u67 & JRE8u20.

    The suggest workaround (user: 2709705) -> install the english language pack.

    Maybe a interessting information -> I saw the "Restore Java security promts" dialog the first time after the english language pack installation & the default display language switch.

    Restore Java security prompts.png

    Regards,

    Steve

    PS: I had a problem to install the english language pack on my Windows 8.1 machine -> the language pack wasn't available .... the answer of this form thread fixed my problem: Language Pack not usable message in Windows 8.1

  • 07a47150-08b1-4a18-b1bf-86382669cef6
    edited Oct 10, 2014 11:47AM

    Hello Folks!

    I do have the same problem here. Actually installed is Java JRE 1.7 (7.0.600.19), and I wanted to upgrade to version 7u65 or 8u20, but without success.

    Here I use Windows 8.1 Pro, German version, and the notebook is also part of a domain network, but not always connected to it.

    Both options to try to install the Java update are failing: connected to the domain network or not connected... :-(

    Error message reports, that Java-Update has not been finished. Errorcode: 1603.

    When I read the messages, I recognize, that there are several users, who are having the same problems to update Java. I would be thankful to Oracle for some support...

    2014-10-10_17-21-58_Fehlermeldung_Java_Update.jpg

  • whats going on with this fu..ing Oracle, 4 months without a reaktion about this installer bug. the language setting workaround is for enterprise definitifly not aceptable. Oracle it is time to do something!

  • 2727771
    2727771 Member Posts: 4

    The bug is finally fixed. Can anyone in Oracle say anything about when you will release a version with this fix included? I hope you can rerelease Update 67 with this fix included.

This discussion has been closed.