Forum Stats

  • 3,874,234 Users
  • 2,266,700 Discussions
  • 7,911,777 Comments

Discussions

error in invoking target 'nmo' of makefile ins_sysman.mk

2707496
2707496 Member Posts: 1
edited Jul 10, 2014 9:54PM in Database Installation
Hi all,

I am trying to install 11gR2 in RHEL 5.3 machine;

but I am getting the following error in the UI

error in invoking target 'nmo' of makefile ins_sysman.mk
this is the make.log trace

/u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/ins_emagent.mk:113: warning: overriding commands for target `nmosudo'
/u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/ins_emagent.mk:52: warning: ignoring old commands for target `nmosudo'
gcc -o /u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/nmo -L/u01/app/oracle/product/11.2.0/dbhome_1/lib/ -L/u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/ -L/u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs/ `cat /u01/app/oracle/product/11.2.0/dbhome_1/lib/sysliblist`  -lm `cat /u01/app/oracle/product/11.2.0/dbhome_1/lib/sysliblist` -ldl -lm -L/u01/app/oracle/product/11.2.0/dbhome_1/lib /u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/s0nmo.o /u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/libnmo.a -lcrypt -ldl    `cat /u01/app/oracle/product/11.2.0/dbhome_1/lib/sysliblist` -ldl -lm
/usr/bin/ld: skipping incompatible /u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs//libdl.so when searching for -ldl
/usr/bin/ld: skipping incompatible /u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs//libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs//libpthread.so when searching for -lpthread
/usr/bin/ld: skipping incompatible /u01/app/oracle/product/11.2.0/dbhome_1/lib/stubs//libnsl.so when searching for -lnsl
/usr/bin/ld: skipping incompatible /u01/app/oracle/product/11.2.0/dbhome_1/lib//libirc.a when searching for -lirc
/usr/bin/ld: skipping incompatible /u01/app/oracle/product/11.2.0/dbhome_1/lib/libirc.a when searching for -lirc
/usr/bin/ld: cannot find -lirc
collect2: ld returned 1 exit status
make[1]: *** [/u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib/nmo] Error 1
make[1]: Leaving directory `/u01/app/oracle/product/11.2.0/dbhome_1/sysman/lib'
make: *** [nmo] Error 2


[[email protected] lib]# rpm -qa --queryformat "%{NAME}-%{VERSION}.%{RELEASE} (%{ARCH})\n" grep libgcc
libgcc-4.1.2.54.el5 (i386)
libgcc-4.1.2.54.el5 (x86_64)
grep-2.5.1.54.2.el5 (x86_64)
[[email protected] lib]# rpm -qa --queryformat "%{NAME}-%{VERSION}.%{RELEASE} (%{ARCH})\n" grep glibc-devel
glibc-devel-2.5.118.el5_10.2 (i386)
grep-2.5.1.54.2.el5 (x86_64)
glibc-devel-2.5.118.el5_10.2 (x86_64)

Can any one help?

Tagged:

Answers

  • Chandru-Oracle
    Chandru-Oracle Member Posts: 35 Employee

    Hi

    Thanks for using community, please make sure you met all the pre-requisite RPMs per the install guide.

    Make sure you have all required rpms like x86_64 or i686/i386 version of it. This error comes on a missing rpm.

    Thank you

    Chandra

This discussion has been closed.