Forum Stats

  • 3,768,284 Users
  • 2,252,770 Discussions
  • 7,874,514 Comments

Discussions

EM Database Express 12c (12.1.0.2.0) doesn't work on any secure HTTPS port

I am running the newest Oracle 12c database release 12.1.0.2.0 x86_64 Enterprise Edition on Oracle Linux 6.5 x86_64. The installation is performed as default database installation and configuration via runInstaller GUI without any problem. Unlike the prior release 12.1.0.1.0 where everything was working fine, EM Database Express 12c of the newest release 12.1.0.2.0 doesn't work on any HTTPS port, although the database itself is working perfectly. EM Database Express can be connected only to HTTP port, if a HTTP port is configured. The browser is Firefox. For instance (for HTTPS port 5500):

SQL> EXEC dbms_xdb_config.sethttpsport(5500);

PL/SQL procedure successfully completed.

SQL> SELECT dbms_xdb_config.gethttpsport FROM dual;

GETHTTPSPORT

------------

        5500

but the URL

https://proton.example.com:5500/em

doesn't work. The same is true with any other HTTPS port if configured. This doesn't happen in the prior release 12.1.0.1.0.

On the other side, when normal HTTP port is configured, for instance

SQL> EXEC dbms_xdb_config.sethttpport(8080);

PL/SQL procedure successfully completed.

SQL> SELECT dbms_xdb_config.gethttpport FROM dual;

GETHTTPPORT

-----------

       8080

the URL

http://proton.example.com:8080/em

works fine. And any other HTTP port works fine.

The listener listens on both ports: 5500 (HTTPS) and 8080 (HTTP).

[[email protected] ~]# netstat -anp | grep 5500

tcp        0      0 :::5500         :::*         LISTEN      7701/tnslsnr


[[email protected] ~]# netstat -anp | grep 8080

tcp        0      0 :::8080         :::*         LISTEN      7701/tnslsnr

Does anybody know what's wrong here and how to setup a secure HTTPS port for EM Database Express 12.1.0.2.0? Thanks in advance.

This discussion has been closed.