Forum Stats

  • 3,872,904 Users
  • 2,266,488 Discussions
  • 7,911,378 Comments

Discussions

Unable to connect ORACLE11g using the oracle 11g driver from MS Access

user3514148
user3514148 Member Posts: 3
edited Oct 5, 2014 10:15AM in ODBC

Hi,

We have an MS Access application that connects to ORACLE to pull the data. We are using the ODBC based DSN to connect to the Oracle. As of now we are trying to configure the DSN using the ODBC driver 'Oracle in OraClient11g_Home1'. We configured the TSN successfully in the TSNNAMES.ORA in the ORACLE HOME directory. The TSN name is appearing in the DSN configuration window. But when I tried to Test the Connection it is failing. the ODBC error is thrown with error number M004. Anyone please help in resolving the issue. We have configured the ORACLE_HOME and TSN_ADMIN in the environment variables. Earliest help is appreciated.

Regards,

KALYAN

Answers

  • Also the error we are getting is "ERROR [IM004] [Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed".

    The ORACLE 11g is lying on Unix. The MS ACCESS application is in Windows 2003 Server

  • Sdhamoth-Oracle
    Sdhamoth-Oracle Member Posts: 189 Employee

    Check if %ORACLE_HOME%\bin is in PATH environment variable. It may cause IM004 error on Windows.

  • We have tried this option, still we are getting the IM004 Error. The ORACLE_HOME is set and the required TNS configurations are done in the TNSNAMES.ORA.

    The TNS Names are appearing in the List while trying to configure the DSN connection. But when we opt for the test connection, we are getting the IM004 error. If we remove the Oracle Home BIN reference in the environment variables we are getting IM003 error.

    Is there any constraint with the connectivity to the UNIX based ORACLE from the Windows 2003 server.

    Regards,

    KALYAN

  • Sdhamoth-Oracle
    Sdhamoth-Oracle Member Posts: 189 Employee

    If you're using remote desktop session, you can try adding "Create Global Objects" privilege for remote desktop user in your server's local policy settings. That may resolve this issue.

    Thanks & Regards,

    Senthil

This discussion has been closed.