Forum Stats

  • 3,734,171 Users
  • 2,246,900 Discussions
  • 7,857,146 Comments

Discussions

Unable to connect to remote host .. (netbeans works, solaris studio 12.4 - beta 2 doesn't). It stays

Unable to connect to remote host .. (netbeans works, solaris studio 12.4 - beta 2 doesn't).

It stays forever in connecting to host.

Is this a known issue in beta?

Best Answer

  • user7444929
    user7444929 Member Posts: 3
    Accepted Answer

    Found the solution.

    It seems it needs "AllowTcpForwarding" in the /etc/ssh/sshd_config set to "yes".

    After that it was able to connect to the remote host. However, an error message should be throw by the IDE.. not to wait forever and ever...

    # Port forwarding

    AllowTcpForwarding yes

Answers

  • It seems that the "dbxTool" from the same version Oracle Solaris Studio 12.4 is working fine and is able to connect to the remote host.

  • user7444929
    user7444929 Member Posts: 3
    Accepted Answer

    Found the solution.

    It seems it needs "AllowTcpForwarding" in the /etc/ssh/sshd_config set to "yes".

    After that it was able to connect to the remote host. However, an error message should be throw by the IDE.. not to wait forever and ever...

    # Port forwarding

    AllowTcpForwarding yes

  • user7444929 написал(а):
    
    Found the solution.
    It seems it needs "AllowTcpForwarding" in the /etc/ssh/sshd_config set to "yes".
    
    After that it was able to connect to the remote host. However, an error message should be throw by the IDE.. not to wait forever and ever...
    
    # Port forwarding
    AllowTcpForwarding yes
    

    Small additional comment. AllowTcpForwarding is not needed in order to connect host, build project or launch executable file. With "AllowTcpForwarding false" you can't load executable into Dbx (debugger) only. But in this case a special window appears:

    =============================================================

    Cannot get a tunnel lll on ssh port 22.

    Possible remedies:

    - Ensure that 'sshd' is running on 'lll'.

    - Ensure that 'AllowTcpForwarding' is set to 'yes' in '/etc/ssh/sshd_config' on 'lll'.

    - Ensure that sshd on lll is listening on port 22.

    Additional info:

    cannot create tunnel -- Tunneler: Couldn't get port after 40 attempts.

    =============================================================

This discussion has been closed.