Forum Stats

  • 3,758,164 Users
  • 2,251,349 Discussions
  • 7,870,080 Comments

Discussions

Why do I get "Errorcode 1603" and Java installation did not finish msg?

Hi, No matter what I do I can't install Java on my windows 7 (Ultimate version)PC.

Keep getting errorcode1603 msg. Java installation did not succeed.

I've removed all old installations and done clean install with same result numerous times

Trying to run RAIDAR (to connect to my Readynas Duo) I get this msg...

"No JVM could be found on your system.

Please define EXE4J_JAVA_HOME to point to an installed 32-bit JDK or JRE or download a JRE from www.java.com."

Trying to install Java only results in 1603 msg

Windows 7 64 computer

Sony Vaio brand

Done removal of Java and register cleaning and retried to install with same result.

I have tried:

MicrosoftFixit.ProgramInstallUninstall.MATSKB.Run.exe

jre-7u72-windows-i586.exe

jre-7u72-windows-x64.exe

jre-8u31-windows-i586.exe

jre-8u31-windows-x64.exe

JavaRa

Done the register java removal suggested on webpages

Manually removed Java and Sun folder/libraries in program, program86 and program data systemfolders.

What to do now?

fad2eb4b-d7e3-4438-b032-204f79e30d0060fd11f5-d43d-47b0-b68a-c0f15f020e60user8659311517652
«1

Answers

  • AndrewKoransky
    AndrewKoransky Member Posts: 2
    edited Mar 26, 2015 3:37AM

    Here's what I do to get around this:

    1. Close the installer when you see Java error 1603.  (It has installed a bunch of files, but exits prematurely.)
    2. Open javacpl.exe from C:\Program Files (x86)\Java\jre1.8.0_XX\bin (or for x64, C:\Program Files\Java\jre1.8.0_XX\bin) where XX is the update number.
    3. Uncheck "Enable Java content in the browser" on security tab and click OK to close Java control panel
    4. Retry installing Java.  It usually succeeds for me this time.
    5. Open javacpl.exe again (see step #2)
    6. Check Enable Java content in browser on security tab and click OK to close Java control panel
    7. If it still fails, try uninstalling windows update KB2918614, then reboot and try these steps again.


    Usually I do not have to mess with step 7.  I have to do this on EVERY system I install Java on at one of my clients.  The systems I'm working on are on a domain and I'm in the domain Administrator account during installation.  All fully up to date Win 7 x64 systems with latest windows updates.  This is very annoying, and I sure hope Oracle fixes this very soon.



    fad2eb4b-d7e3-4438-b032-204f79e30d0060fd11f5-d43d-47b0-b68a-c0f15f020e60
  • fad2eb4b-d7e3-4438-b032-204f79e30d00
    edited Apr 22, 2015 2:44PM

    Its been two weeks of searching and trying (not full time searching).  This finally did it!!

    Here is how I got it to work:

    Install Java 32Bit and let it fail.

    Uncheck the "Enable Java Content..."

    Install Java 32Bit.

    Check the "Enable Jave Content..."

    Install Java 64Bit and let it fail.

    Uncheck the "Enable Java Content..."

    Install Java 64Bit.

    Finally Check the "Enable Java Content..."

  • AndrewKoransky
    AndrewKoransky Member Posts: 2
    edited Apr 23, 2015 3:40PM

    This is still failing in the same manner with the latest JRE 8u45.  Same workaround works, but having to maintain this on 20 computers is a pain.  Is anyone from Oracle going to ever fix this?

  • 3007068
    3007068 Member Posts: 2
    edited Aug 6, 2015 6:41AM

    This is really surprising that the issue is not fixed so far....

  • 276c2c2e-0e87-4f09-8102-c1028157ea29
    edited Sep 15, 2015 5:06PM

    Thanks Andrew so much for your help!

    uninstalling windows update KB2918614, then reboot totally worked for me.


  • 8c2d1e2d-8858-4b38-9056-1817ec5bfe4b
    edited Sep 20, 2015 3:46PM

    Hi, I'm having the same issue listed here, or at least similar.  While I get the error 1603 message when trying to install, I can't follow the steps posted by Andrew because javacpl.exe just refuses to do anything when I try to open it.  Anyone have a suggestion?  Thanks.

  • Simon Platten
    Simon Platten Member Posts: 2
    edited Sep 21, 2015 6:46AM

    I've spent most of this morning trying to resolve this problem, I have two small embedded PC's running Windows 7 embedded.  I installed JRK 8u60 and JRE 8u60 on the first PC without issue, however on the 2nd PC I kepted getting the 1603 error.

    I tried just about everything, however in the end for me, it turned out the these systems were low on memory, on the system that worked I have virtual memory set-up, but on the system that didn't install it had no virtual memory set-up.

    I then edited the set-up, setting the virtual memory to initially 4096, with an upper limit of 16384.  Tried the install again and it worked without any errors, from what I've read it would seem that the error code 1603 can be caused by lots of different reasons, but for me it was low resources.

    Hope this helps.

  • 00c82232-7818-412d-b418-c809ad31a1c3
    edited Sep 24, 2015 3:07AM

    Andrew that worked like a charm. You are the man! What a stupid problem to have. No wonder Google removed Java support from Chrome.

  • George Perkins
    George Perkins Member Posts: 8
    edited Nov 23, 2015 11:38AM

    I had to disable McAfee VirusScan Enterprise 8.8 on-access scanning. This allowed the Java JRE 8 install to complete. See java update did not complete error code 1603 windows

  • 3135043
    3135043 Member Posts: 2
    edited Dec 7, 2015 7:44PM

    I completely removed Java, all it's folder, it's registry entries, literally everything about it and still got the 1603 error.

    I fixed it by removing the "_JAVA_OPTIONS" environment variable, which gets installed by some Java debugging programs.

    user8659311517652
This discussion has been closed.