Forum Stats

  • 3,732,985 Users
  • 2,246,665 Discussions
  • 7,856,453 Comments

Discussions

I installed the SQL developer 4.0 and the repository installation was successful. But the tools --->

user8829660
user8829660 Member Posts: 8
edited March 2015 in Machine Learning

I installed the SQL developer 4.0 and the repository installation was successful. But the tools ---> Data Miner ----> Make visible option is not enabled .Also that when I  double click on the data miner  user connection I am getting the message The repository workflow data must be stored in binary xml format on databases of version 11.2.0.4 or greater. Would you like to migrate your worklfow data to binary storage?  WARNING: All sessions with the ODMRUSER role will be disconnected.  Client Version: 12.2.0.17.29 Repository Version:12.1.0.2.1 Database Version:12.1.0.1.0  . I dont have an older repository. Please help me to resolve this issue.

user8829660

Best Answer

  • Denny Wong-Oracle
    Denny Wong-Oracle Member Posts: 183
    edited March 2015 Accepted Answer

    Try create a data miner user account (e.g. DMUSER) using the createuser.sql script found in the <SQL Developer>\dataminer\scripts directory.  Use this user account to connect instead of the anonymous account.

    Thanks.

    user8829660user8829660

Answers

  • Denny Wong-Oracle
    Denny Wong-Oracle Member Posts: 183
    edited March 2015

    Hi

    Did you install the SQL Developer 4.1 EA1 version?  Was this a fresh install?  Was the db migrated from earlier version (e.g. 11.2) ?

    There is a new version of SQL Developer (4.1 EA2), please try this one to see if the problem persists

    SQL Developer 4.1 Early Adopter

    Thanks

  • user8829660
    user8829660 Member Posts: 8
    edited March 2015

    Thanks a lot  for the reply. I freshly installed Oracle 12c release 1 and sql developer 4.1.0.17  (EA1 version).The db was not migrated from a earlier version. After installing the migration  repository  successfully via sqldeveloper I am getting the message as earlier but the tools ---->Data Miner ----->Make Visible option is enabled now.

    . When I analyzed the log the error is

    Error starting at line : 9 File @ C:\sqldeveloper-4.1.0.17.29-no-jre\sqldeveloper\dataminer\scripts\upgradeRepo12_1_0_1_5To12_1_0_2_1.sql

    In command -

    ALTER TABLE "ODMRSYS"."ODMR$WORKFLOWS" ADD(RUN_NODES ODMRSYS.ODMR_OBJECT_NAMES)

      NESTED TABLE RUN_NODES STORE AS ODMR_RUN_NODES_TAB

    Error report -

    SQL Error: ORA-01430: column being added already exists in table

    01430. 00000 -  "column being added already exists in table"

    *Cause:   

    *Action:

    Commit

    So the error occurs during upgrade of the migration repository from 12.1.0.2.1 to 12.2, Currently the

    Client Version: 12.2.0.17.29

    Repository Version:12.1.0.2.1

    Database Version:12.1.0.1.0 as per sql developer.

    Please let me know if it would be ideal for me to upgrade the repository manually or install SQL Developer (4.1 EA2) . Also please let me know where I can find the steps to upgrade the repository manually if needed.

  • Denny Wong-Oracle
    Denny Wong-Oracle Member Posts: 183
    edited March 2015

    Please install the SQL Developer (4.1 EA2).  When you open a data miner user connection, it should perform necessary migration.  Alternatively, you can drop the repository (Data Miner -> Drop Repository) and let the client reinstall a fresh repository.


    Thanks.

  • Denny Wong-Oracle
    Denny Wong-Oracle Member Posts: 183
    edited March 2015

    Hi

    When you said "After installing the migration repository successfully via sqldeveloper" in your previous reply, how did you migrate the repository?  I thought this was a fresh installation of the repository.  I am just trying to figure out how the "upgradeRepo12_1_0_1_5To12_1_0_2_1.sql" was invoked in the first place - this script should only be invoked when a repository migration is necessary.


    Thanks.

  • user8829660
    user8829660 Member Posts: 8
    edited March 2015

    Thanks for the reply.  I installed the new version of SQL Developer (4.1 EA2). I made anonymous user as the data miner user by unlocking it. Please see the screenshot attached. When I  right click on the anonymous user to create a new project that's when I get the message to upgrade the older repository . I proceed to upgrade the repository via the wizard in the sql developer. Now it gives me no errors but it never gets completed. I get the same message to upgrade respository again and again .And I dont see any option to create workflows and I dont see any component options also . Your understanding is correct .This is totally a fresh install of Oracle 12c release 1 database and SQL developer.

    Please let me where I am going wrong. This will be really helpful to mine our data if this can be fixed.

    Thanks again.

    error screenshot.png

  • Denny Wong-Oracle
    Denny Wong-Oracle Member Posts: 183
    edited March 2015 Accepted Answer

    Try create a data miner user account (e.g. DMUSER) using the createuser.sql script found in the <SQL Developer>\dataminer\scripts directory.  Use this user account to connect instead of the anonymous account.

    Thanks.

    user8829660user8829660
  • user8829660
    user8829660 Member Posts: 8
    edited March 2015

    Thanks a lot for all your help .Creation of new user did the trick. It worked and am able to use Oracle data miner now.

This discussion has been closed.