Forum Stats

  • 3,851,489 Users
  • 2,263,988 Discussions
  • 7,904,739 Comments

Discussions

Oracle Enterprise Pack for Eclipse issue - need it to work with JDK 1.7

2903662
2903662 Member Posts: 3
edited Aug 15, 2015 3:45PM in Enterprise Pack for Eclipse

Please let me know if there's a more appropriate forum - thanks.

I need to install OEPE into Eclipse STS (luna) using JDK 1.7.  I did this 2 months ago without a problem but had to recently reinstall.  I get the error, 'Oracle Enterprise Pack for Eclipse requires Java 8 or higher'.  I need to find the older version of OEPE that works with JDK 1.7.

I saw that the current OEPE installs 'Oracle WebLogic Scripting Tools' and 'Oracle WebLogic Server Tools' with version 7.3.4.  I remember that when I previously (successfully) installed OEPE into STS, the versions for these were 7.3.3.  I googled and found Oracle Enterprise Pack for Eclipse 12.1.3.4 and installed it from there.  I saw that the versions of the above 2 items are now 7.3.3 but ... I still receive the same error.

Note:

- STS: Version: 3.6.4.RELEASE  Build Id: 201503100339   Platform: Eclipse Luna SR1 (4.4.2)

- My weblogic install is weblogic 12c

Any help?

Thanks,

Bill

«1

Answers

  • Kosta-Oracle
    Kosta-Oracle Member Posts: 461
    edited Mar 13, 2015 12:28PM

    The last OEPE version that will run on Java 7 is 12.1.3.3.1, which you can find here:

    Oracle Enterprise Pack for Eclipse (12.1.3.3.1)

    2903662
  • Kosta-Oracle
    Kosta-Oracle Member Posts: 461
    edited Mar 13, 2015 12:30PM

    Note that you have to uninstall the newer version of OEPE before you try to install an older one. Else, the older one will not take precedence.

    2903662
  • Greg Stachnick-Oracle
    Greg Stachnick-Oracle Member Posts: 90
    edited Mar 13, 2015 12:44PM

    In OEPE 12.1.3.4, we raised the minimum level to JDK 8 to launch Eclipse. You can still use JDK 1.7 (and lower) spec levels for the Java compiler and configured runtimes. Are you able to launch your existing Eclipse with Java 8?

    Thanks,
    Greg

    2903662
  • 2903662
    2903662 Member Posts: 3
    edited Mar 14, 2015 11:34AM

    Thanks.  I tried that (I had tried that before) -- Help - Install new software - in 'work with': http://download.oracle.com/otn_software/oepe/12.1.3.3.1/luna/repository/ - expand 'Tools' - check the boxes for 'Oracle weblogic scripting tools' and 'oracle weblogic server tools' .

    I still get the same error.  Note: they show as version 7.3.3.201412231459 except for Oracle Java EE Tools which shows as 7.3.4.201502282121  (is this the issue?)

    Thanks -

    Bill

  • 2903662
    2903662 Member Posts: 3
    edited Mar 14, 2015 11:40AM

    Thanks -- I tried Kosta's suggestion (which I had tried before) but still the same error.

    I realized that on my development install (the rest of my team has a year+ old install) that I installed weblogic 12c version 12.1.3 (they have weblogic 12c 12.1.1).  12.1.3 requires jdk 1.8, correct?  I started eclipse w/ jdk 1.8 & no more error.  I added jdk 1.7 (jdk 1.7.0_45) as the default Java compiler in my Eclipse STS (sts 3.6.4; luna 4.4.2). 

    When I added a weblogic server instance to eclipse, 12.1.3 would not accept the jdk 1 compiler - it needed java 1.8.  So ... I specified that.

    I haven't tried it yet but -- is it ok to compile the code w/ jdk 1.7.0_45 and deploy it to weblogic 12.1.3 that uses jdk 1.8.0_40?

    Thanks,

    Bill

  • dvohra21
    dvohra21 Member Posts: 14,660 Gold Crown
    edited Mar 14, 2015 9:36PM

    Oracle Enterprise Pack for Eclipse (12.1.2.4) to Oracle Enterprise Pack for Eclipse (12.1.3.3.1) support Java 7 & 8.

    Oracle Enterprise Pack for Eclipse Previous Releases

  • Kosta-Oracle
    Kosta-Oracle Member Posts: 461
    edited Mar 16, 2015 2:50PM
    Note: they show as version 7.3.3.201412231459 except for Oracle Java EE Tools which shows as 7.3.4.201502282121  (is this the issue?)

    Yes, that would do it. Oracle Java EE Tools is the base component that has Java version detection. You will need to install version 7.3.3 if you want to run Eclipse with Java 7.

  • Kosta-Oracle
    Kosta-Oracle Member Posts: 461
    edited Mar 16, 2015 2:54PM
    I haven't tried it yet but -- is it ok to compile the code w/ jdk 1.7.0_45 and deploy it to weblogic 12.1.3 that uses jdk 1.8.0_40?

    If the rest of the team is using WLS 12.1.1 with Java 7, you should not be trying to using WLS 12.1.3 with Java 8, as you run the risk of introducing incompatible code into your shared code base.

    Note that the version of Java you run your Eclipse with is completely independent from the version of Java you target with your project. It's perfectly possible to run the latest version of OEPE (12.1.3.4) on Java 8, then target the project to WLS 12.1.1 runtime with Java 7.

  • dvohra21
    dvohra21 Member Posts: 14,660 Gold Crown
    edited Apr 4, 2015 10:06AM

    It's perfectly possible to run the latest version of OEPE (12.1.3.4) on Java 8, then target the project to WLS 12.1.1 runtime with Java 7.


    Compiling a class with Java 8 and running on Java 7 would generate Unsupported major.minor version error.

  • Kosta-Oracle
    Kosta-Oracle Member Posts: 461
    edited Apr 4, 2015 1:44PM
    Compiling a class with Java 8 and running on Java 7 would generate Unsupported major.minor version error.

    This statement is correct, but not relevant to this topic. The latest version of OEPE requires that Eclipse runs with Java 8, but your projects can be configured to compile for any version of Java that's required. When you target a project to a particular WLS installation, OEPE will automatically configure the project to build for the version of Java supported by that WLS version.

This discussion has been closed.