Forum Stats

  • 3,767,998 Users
  • 2,252,739 Discussions
  • 7,874,404 Comments

Discussions

Unable to install 12c 32 bit client on same machine as 12c 64 bit server

876260
876260 Member Posts: 5
edited Dec 17, 2015 4:09AM in Database Installation

I have installed the 64bit 12c server on a Windows Server 2012 R2 machine.  I had the installation create a new user named "oracle".  Now I need to install the 32bit 12c client on the same machine due to an application on the server that doesn't support the 64 bit client.  When I try to install the 32bit client, a console window comes up for a few seconds then goes away and an error window pops up.  The error says "[INS-10102] Installer initialization failed." and when I click the details button, it says "[INS-10002] Inventory initialization failed".  I checked the install log and it ends with the following:

ERROR: Cannot add user to application access ACL.
No mapping between account names and security IDs was done.

(534)

This machine used to have the 32 bit 11g client on it, but that has been completely removed.

I've searched the net, but can't find anything useful for this error.  Can anyone please give me some assistance?

Thanks very much.

Geert GruwezZoltan Kecskemethypinpointuser22247421152131user1141032User_XEA3MUser_N89IZDeepak Maneuser512172Travis99230ec2c7-5e10-4d2d-8418-0d465765763026eb0a5b-cca6-4d25-af2d-6a6bf883fb783325182Mihai Ciocan-Oracle2924915user9023044Grigori Rasputinuser8849338user8260772scanbixslovar2003Jonathan HultSsharva-Oracle29334703814622user6068689user91072953020868
«1

Answers

  • Geert Gruwez
    Geert Gruwez Member Posts: 1,011
    edited May 22, 2015 5:48PM

    you did install the 32 bit in a completely separate folder ?

    there should be no shared folders between the 2 software homes

    did you try the instant client ?

    which version of the client did you try ?

  • Geert Gruwez
    Geert Gruwez Member Posts: 1,011
    edited May 22, 2015 5:50PM

    did you try the install after completely switching off UAC ?

  • 876260
    876260 Member Posts: 5
    edited May 26, 2015 3:57PM


    I believe the install log I was logging at with the error was the one for the server, not the client.  It was under c:\program files\oracle\inventory.  When I checked for the location of the inventory for the 32 bit program, it doesn't exist.  There is no Oracle directory under c:\Program Files (x86) and the registry entry HKLM\SOFTWARE\WOW6432Node\ORACLE\inst_loc does not exist.  The HKLM\SOFTWARE\WOW6432Node\ORACLE entry does exist in the registry but is empty.  I tried deleting that entry from the registry and now the install program gets further.  It allows me to enter all of the information, but when I click the Install button, the window flashes and goes away.  It created the c:\program files (x86)\Oracle\Inventory directory, and it creates the install response file installActions2015-05-26_09-29-22AM.log, but not an install log and it doesn't actually install anything.

    I've tried both runtime and instant client options with the same result.

    I have not tried turning off UAC, never had to do that before on other machines or versions.  If I don't come across another solution today, I can try that tomorrow morning.

  • Geert Gruwez
    Geert Gruwez Member Posts: 1,011
    edited May 27, 2015 2:52AM

    di you right click ... run as administrator ?

    if not, it usually fails

  • 876260
    876260 Member Posts: 5
    edited May 27, 2015 11:14AM

    Run as administrator didn't help.  I've also turned off UAC and that didn't make a difference.

  • 876260
    876260 Member Posts: 5
    edited May 27, 2015 1:58PM

    I reinstalled the 11g 32 bit client, then the install for the 12c 32 bit client worked.  I don't know what the issue was, but it's working now.  Thanks.

    Geert Gruwezuser51217226eb0a5b-cca6-4d25-af2d-6a6bf883fb78
  • Geert Gruwez
    Geert Gruwez Member Posts: 1,011
    edited May 27, 2015 2:13PM

    just a tiny detail is enough to go wrong

  • Zoltan Kecskemethy
    Zoltan Kecskemethy Member Posts: 1,142 Gold Badge
    edited Jun 9, 2015 8:29AM

    10-12 days is not that long reply time in this forum. At least better than never!

    And posting a possible solution is never late IMHO. Since many of us come here to learn...

  • User783738-Oracle
    User783738-Oracle Member Posts: 1
    edited Jun 26, 2015 6:14AM

    Oracle 12C db client release notes https://docs.oracle.com/cd/E11882_01/relnotes.112/e23557/toc.htm says the following.

    Workaround:

    If you are performing the upgrade on a remote node, a node other than the one on which Oracle Clusterware 11g Release 1 (11.1.0.6) was installed, then the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Oracle\inst_loc may not have been set on that node.

    Ensure that you manually set the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Oracle\inst_loc to the location of the Oracle Inventory directory of the node on which you are performing the upgrade installation.

    This issue is tracked with Oracle bugs 9210861 and 6527941.

    slovar2003Jonathan Hult
This discussion has been closed.