Forum Stats

  • 3,827,661 Users
  • 2,260,802 Discussions
  • 7,897,324 Comments

Discussions

apt-get cant install oracle-java8-installer

golze.
golze. Member Posts: 15
edited Oct 29, 2015 12:06PM in Java 8 Questions

Hello,

it is impossible for me to use "apt-get install oracle-java8-installer" on linux (latest and updated debian) cause the download is blocked due too licence aggrement -> 302 Moved Temporarily

I can download the file manually on windows and transfered it to linux (no gui, only remote shell) but a tar.gz file cant be installed, just unpacked and there is no install routine.

Also i must installed it in a way apt-get know it is installed cause other packages try to install oracle-java8-installer cause of depending on it.

How to slove this problem?

Oracle should put the licence aggrement into the package or skip the aggrement if it is not a browser.

Answers