Forum Stats

  • 3,838,749 Users
  • 2,262,397 Discussions
  • 7,900,750 Comments

Discussions

Eclipse Mars + Glassfish Tools 8.6.1 -> Error getting URL for WebResource

Thomas Kernstock
Thomas Kernstock Member Posts: 4
edited Apr 4, 2016 3:38PM in Enterprise Pack for Eclipse

Hi @All,

I'm using Eclipse Mars with Oohmp and the "Use bundle" option to install my different eclipse versions. The Glassfishtools are version 8.6.1.

When deploying an application with "Run on server" I receive:

GlassFish: Error getting URL for WebResource [module=Module[ISG-BKSelfservice,org.eclipse.jst.jee.server:ISG-BKSelfservice], path=]

java.lang.NullPointerException

    at org.eclipse.jst.common.internal.modulecore.SingleRootExportParticipant.getMembers(SingleRootExportParticipant.java:151)

    at org.eclipse.jst.common.internal.modulecore.SingleRootExportParticipant.optimize(SingleRootExportParticipant.java:103)

    at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.optimize(FlatVirtualComponent.java:212)

    at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.cacheResources(FlatVirtualComponent.java:186)

    at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.getChildModules(FlatVirtualComponent.java:160)

    at org.eclipse.wst.web.internal.deployables.FlatComponentDeployable.getExportModelChildren(FlatComponentDeployable.java:252)

    at org.eclipse.wst.web.internal.deployables.FlatComponentDeployable.getModules(FlatComponentDeployable.java:263)

    at org.eclipse.jst.server.core.internal.J2EEUtil.getEnterpriseApplications(J2EEUtil.java:95)

    at oracle.eclipse.tools.glassfish.AbstractGlassfishServer.getRootEarModulesOnThisServer(AbstractGlassfishServer.java:927)

    at oracle.eclipse.tools.glassfish.AbstractGlassfishServer.getModuleRootPath(AbstractGlassfishServer.java:888)

    at oracle.eclipse.tools.glassfish.AbstractGlassfishServer.getModuleRootURL(AbstractGlassfishServer.java:869)

......

- The application I try to deploy worked fine until recently on Glassfish 3.1.1.

- I can install the war directly on the server with no problems on Glassfish 3.1.1 and Payara 4.1

- I'm using a glassfish-web.xml as suggested in former posts.

- When I try to add the application to the server with "Add and remove" I see -> "There are no resources that can be added or removed from the server"

     This is the case since a long time ago, but until now I was able to deploy by "Run on server" without a problem.

- I uninstalled the Glassfishtools and tried using an older version (8.6.0 and 8.5.0) but this didn't work too.

- I created a completely new workspace and a new dummy project. This could be added to the server once. As soon as I imported my projects from git and tried to deploy them I ran into the same error as above. From that moment on I also coundn't readd the newly created dummyproject.

This situation is rather serious because I'm not able use eclipse to work on my project, so I hope you can help me out with this

Thank you in advance

Thomas

Answers

This discussion has been closed.