Forum Stats

  • 3,768,266 Users
  • 2,252,770 Discussions
  • 7,874,511 Comments

Discussions

How do I recover the data from my database after an Oracle uninstall?

mmunoz270
mmunoz270 Member Posts: 2
edited Sep 7, 2016 5:09AM in General Database Discussions

The problem I'm facing is that: my team has one shared laptop with another team, we used to have two working instances of Oracle Database 11g each with it's respective database, "ORLC" and "BDSAI". Thing is that this other team whe share the computer with, tried to create a database, installed an Oracle Database 11g Express Edition and after that uninstall it (because "it didn't work").

Now the databases of my team aren't working. The services cannot be started (see screenshot), how can I fix this? A reinstallation of Oracle Database 11g would work? Why are the oracle services still listing in the services window?

services.png

Any help or orientation would be greatly appreciated,

PD. Sorry for my English

EDIT:

There aren't any backups, I don't know where the data files are, and I'm getting a control file error: ORA-002055

So far what I have done is:

1. Windows Recovery to the point before the Oracle Express Edition

2. Copied all the files that were missing in ORACLE_HOME/bin from another computer

3. Temporary set ORACLE_SID to "ORCL"

4. Now the services are working and started OracleServiceORCL and OracleVSSWriterORCL

5. I logged in in SQL Plus as "/ as sysdba"

6. Tried to execute "startup;" but failed

7. I looked for the spfiles in the ORACLE_HOME/database, there were SPFILEBDSAI.ORA and SPFILEORCL.ORA

8. Returned to sql plus and executed "create pfile from spfile;"

9. Now a INITorcl.ORA file was created in ORACLE_HOME/database

10. Tried again "startup;" in sql plus, failed because of the db_recovery_file_dest parameter

11. Created the folder in the route that was missing

12. Now the .control_files parameter fails

Should I try with the CREATE CONTROLFILE ?

Mensaje editado por: mmunoz270

Tagged:
AndrewSayer

Best Answer

  • Igor Laguardia-Oracle
    Igor Laguardia-Oracle Member Posts: 53
    edited Sep 5, 2016 7:53AM Accepted Answer

    I'd say that your database files/control files/ redo log files/ where removed, and from the services that still on your services window I can say that the Oracle wasn't de-installed(using OUI to de-install removes services) properly.

    Best case scenario, they removed the Oracle installation manually(deleting the installation folder) and you still have your database files, on this case, reinstall Oracle will make it work again(setup is required).

Answers

This discussion has been closed.