Forum Stats

  • 3,827,130 Users
  • 2,260,743 Discussions
  • 7,897,180 Comments

Discussions

JDK 1.6.0_26 support for TLSv1.1

user580543-Oracle
user580543-Oracle Member Posts: 55 Employee

Hi ,

We are using JDK 1.6.0_26.

We need to invoke rest WS which works using TLSv1.1.

We tried using java.lang.System.setProperty("https.protocols", "TLSv1.1"); 

But it throws

java.lang.IllegalArgumentException: TLSv1.1

  at com.sun.net.ssl.internal.ssl.ProtocolVersion.valueOf(ProtocolVersion.java:133)

  at com.sun.net.ssl.internal.ssl.ProtocolList.<init>(ProtocolList.java:38)

Can anyone please help here as we can not upgrade Java on production immediately.

Thanks,

Vani

stephane.365

Answers

This discussion has been closed.