Forum Stats

  • 3,770,203 Users
  • 2,253,081 Discussions
  • 7,875,363 Comments

Discussions

Illegible or invisible fonts in dbca using X server in OEL7

Javier-Garduño-M-Oracle
Javier-Garduño-M-Oracle Member Posts: 6
edited Jan 13, 2017 3:43PM in Database Installation

Hello Masters.

I am using Oracle Linux 7.2 installed from an OBI image. When I try to install a database (12.1.0.2) by using runInstaller script in a virtual machine with Oracle Linux 6.6 running in VirtualBox (5.0.26), I get an installation  window with illegible fonts. In the beginning I thought it was due to my hots OS needed fonts packages because I had already opened the runInstaller script in my virtual machine correctly, but after install all the fonts packages in my host OS based on the packages included in the virtual machine, I did not see changes. My second attempt was to use the same Oracle Database software in my host in order to run the runInstaller script without an ssh connection, that execution was successful, After, I used a ssh connection from my host to my host and after execute the runInstaller script I got an installation window with illegible fonts again, also I tried to run NETCA, NETMGR and DBUA but I saw the same problem, however running SLQDeveloper it shows the fonts correctly.

Could someone help me to discover and fix the problem?

Additional information:

My java version is 1.8.0_101.

My OS has all updates until November 17, 20016.

Selecting with pointer some illegible fonts they become legible.

Screenshot from 2016-11-17 15-12-23.png

Tagged:
«1

Answers

  • Gbenga Ajakaye
    Gbenga Ajakaye Member Posts: 3,422 Gold Trophy
    edited Nov 17, 2016 5:13PM

    what error code do you get? Can you check your alert log and post error - relating to this issue?

    It looks like you might not have the right fonts. Are you using anything else as your X server?

    Javier-Garduño-M-Oracle
  • Javier-Garduño-M-Oracle
    Javier-Garduño-M-Oracle Member Posts: 6
    edited Nov 17, 2016 7:18PM

    Thank you for you reply Gbenga.

    After checking the log created by the runInstaller script, I realized that there are no errors, also, I compared the log generated by an direct execution (I mean with no ssh connection) and both files are almost the same except for the "hash" depending of execution (eg. [email protected] , [email protected]).

    I am checking the log that runInstaller windows shows before to close and I am not using anything else as my X server.

    I think the problem is related with the xorg fonts, I but I already installed all of them, I will install old versions and check again.

  • Gbenga Ajakaye
    Gbenga Ajakaye Member Posts: 3,422 Gold Trophy
    edited Nov 17, 2016 7:52PM

    Sounds good. Be sure to reply back with what works.

    I think that you might need to install Xming-font.

  • Dude!
    Dude! Member Posts: 22,826 Black Diamond
    edited Nov 17, 2016 7:56PM

    What clues exist that this has anything to do with fonts? As I recall, such issues are typical for problems with the video driver. Have you tried disabling 2D/3D acceleration in the virtual machine settings?

  • Javier-Garduño-M-Oracle
    Javier-Garduño-M-Oracle Member Posts: 6
    edited Nov 28, 2016 1:40PM

    I appreciate your reply guys.

    Gbenga. I tried to install Xming-font but I did not find the package in the official repository  I also installed the oldest Xorg packages available for OEL7 but results were the same.

    Dude!, I was testing a virtual machine with an OEL7.2 inside, which is exactly the same OS that I am using as Host and all worked correctly, in other words, windows inside the virtual machines (OEL6.6, OEL7.2) are shown correctly. due to this tests I think the problem is related to the host video driver.

    My laptop model is Lenovo T450, I will check  drivers for this specific model and I will share the results. Thanks to both of you.

  • EdStevens
    EdStevens Member Posts: 28,533 Gold Crown
    edited Nov 28, 2016 1:52PM

    I have nothing to add, but will be watching this one closely, as it looks suspiciously like the issue I posted at Rendering of GUI x11

    In my case, running a virtual guest with OL6, on a host running Ubuntu 16.04.  I had considered the xming-fonts (I had to deal with that once one a Windows host), but since I'm not running xming, didn't seem appropriate.

  • Javier-Garduño-M-Oracle
    Javier-Garduño-M-Oracle Member Posts: 6
    edited Nov 28, 2016 3:21PM

    EdStevens, I saw your posts and it seems to be the same problem, I already tested the change recommended by Dude! to set antialiasing=RGBA even in many desktops like gnome, KDE and Cinnamon but I have no changes, I have the latest version of Intel video driver installed as well (xorg-x11-drv-intel-2.99.917-22.20151206.el7.x86_64) so I see it so weird because in my case same installation only works correctly in a virtual machine.

  • Dude!
    Dude! Member Posts: 22,826 Black Diamond
    edited Nov 28, 2016 4:17PM

    I don't think this has anything to do with fonts. I think it's a problem with the video driver or a hardware defect.

  • Pavan Kumar
    Pavan Kumar Member Posts: 11,904 Gold Crown
    edited Nov 29, 2016 4:50AM

    Hi,

    Is it possible to test with vmware and verify does the issue persists. Is it possible to get fresh OEL 7 or 6 from edelivery.oracle.com and re-try

    - Pavan Kumar N

  • Javier-Garduño-M-Oracle
    Javier-Garduño-M-Oracle Member Posts: 6
    edited Nov 29, 2016 1:38PM

    Hi Pavan, I will try with vmware and I executed the tests with a fresh OEL7 OBI image from mydesktop.oraclecorp.com and  a OEL6 image from edelivery.oracle.com.

    Please let me emphasize the fact that this problem appears in my host only, running the tests in virtual machines, windows and fonts are shown correctly.

This discussion has been closed.