Forum Stats

  • 3,769,982 Users
  • 2,253,043 Discussions
  • 7,875,258 Comments

Discussions

Is there any activity out there on Java ME?

3345501
3345501 Member Posts: 12
edited May 19, 2017 3:12AM in Java ME Embedded

Yes, I'm an old man. This is true. But w.r.t. knowledge, I think, I'm stronger than ever. As an electronic engineer, I developed HW, built analog filters and embedded computers. As a SW-engineer, I developed SW for microcontroller steered embedded systems and I developed SW for JEE, up to EE7. I accessed the hardware of unix machines using Java 1.4 through C and Perl-Programs. Having this knowledge, I must ask, why is it so difficult to start with Java-ME? Almost nothing works. eclipse neon is producing error-reports w.r.t. internal error one after the other with a 5 minute cadence. Signing the SW is a real mess, no usable help available. I also tried netbeans. Even worse. JAVA-ME was declared as well as the JDK 8. No help. It didn't compile. @override tags were declared as error, like a simple try to do a logging, or to do a system write to the console. Yes, I was looking for a challenge, using once Java-ME. But I guess it was a big mistake. Doing the same from normal java connecting through c-libraries to the HW is definitively much simpler. I thought Java ME was built to make it simpler. And now the worst of all looking into the forum, nothing is answered. Hence my question in the subject! Does Oracle still have any interest in Java?

I'm sorry for this negative thinking. Normally I'm very positive and used to achieve, what ever I intend to do. But fighting errors done by others, is frustrating and I need a feedback, that at least one person was able to use Java-ME accessing HW and get a result out as expected.

Answers

  • bjuntti
    bjuntti Member Posts: 14
    edited Jan 1, 2017 10:06PM

    Hi,

    Most of my work like I was a system administrator (over 30 years so I'm old too :-)  ), but I have been bitten by the Java bug and more recently the Raspberry Pi/JavaME bug.  I took the Java MicroEdition MOOC (Massive Online Oracle Course) and it was great.  Sorry to hear you're having bad feelings about Java.  Sometimes it seems nobody else is using Java or ran into the same issues you have had.  I'm having that same issue with JavaME and Javadoc - can't find squat about using Javadoc on Netbeans for JavaME.   It is frustrating.   I'm hanging in there hoping SOMEBODY will have the answers.   I'm trying to build a website with a FAQ about every tough nut and solution that I've found.  Hang in there!

    Bruce

  • Jose Cruz
    Jose Cruz Member Posts: 6
    edited Jan 17, 2017 11:29PM

    Dear Friend

    I am using Java ME with Raspberry Pi with a lot of examples here

    Best regards

  • 2833902
    2833902 Member Posts: 23
    edited Jan 19, 2017 4:07PM

    Hi There,

    A bit surprised to hear setting-up Java ME was so cumbersome for you, to be honest. I installed it, set it up in Eclipse (through the plugins) a couple of days ago and I was able to run a simple MIDlet in the emulator in, I think, less than hour. Hooking-up RasPi, installing Java ME on it and connecting with the device manager was even easier.

    I followed the instructions here: Java Micro Edition Software Development Kit Developer’s Guide - Contents  (not sure if it makes any difference at all, but I'm using Ubuntu Linux).

    My background is in Enterprise Java so I can't really judge subjectively but I have found the tooling offered by the Java ME JDK (such as the emulator) quite feature-rich and very helpful and, as proclaimed by Oracle, offers the exact same behaviour as you'd get if you ran your app in the actual device.

    Having said all that however, today I realised that after upgrading Java SE the emulator in Java ME stopped working which  is causing the Eclipse plugin not to load properly which in turn is causing Eclipse itself not to load... :-)

    Not sure if anyone else had the same issue but I'll create a post here and see.

  • 3345501
    3345501 Member Posts: 12
    edited Jan 25, 2017 5:19AM

    This question is not in the forum since 6 days, but since 2 month and still no reaction from Oracle!

  • 3345501
    3345501 Member Posts: 12
    edited Jan 25, 2017 6:08AM

    Yes José, I saw your articles before and I think you have done a very interesting job. But you use a lot of additional HW which I don't have and I'm not willing to buy. And yes, I could take some ideas out of it, but with the CAN-board from skpang.co.uk I'm still struggeling. I don't remember when and how, but for a while I was able to access gpio through JavaME on Raspberry Pi from windows through SSH and I have built also my own RaspiEmulator to set all output pins at will. If I remember correctly the key for some success was to set enable all access rights in the _policy.txt file. An other point which I must search and read again to repeat due to the accident of this morning.

    Told that, I was trying to get access through SPI the CAN-BUS of the mentioned board, not having too much success, but doing small progress. This morning I had the very bad Idea to upgrade jdk from 8u112 to 8u121. Since that the device manager failed to start and after uninstall and install again of JavaME all defined devices are gone. I did this, because I saw the file java in the bin directory still pointing to the previous version of java and as manual correction didn't help, the uninstall/install action took place. I didn't go back to the previous jdk yet to see if this help. Anyway, I guess, I must give priority to other tasks now, putting standby JavaME until Oracle is willing to fix bugs!

    P.S.  The JavaME getting started document could be improved for instance. This document is addressing new comers. People not being aware of the weired numbering schema of Pi. So speaking in the Device I/O List about GPIO pins, it's not enough to mention pinNumber 4 for GPIO4 imperatively it should be menitioned in the same place, that GPIO is connected to the HW-Pin 7! I know it's mentioned later, but for the principle of locality it should be mentioned in the table otherwise it's very confusing.

  • 2f8c02bb-7df5-4846-9a50-d9012e2b9c99
    edited May 19, 2017 3:11AM

    Its now May 2017, which makes 7 months since the question is posted.

    A very relevant question that begs Oracle to respond as this community is within Oracle and there were no other response. Strangely, nothing.

    Anyone can share current activities and implementation on Java ME?

  • BluShadow
    BluShadow Member, Moderator Posts: 41,492 Red Diamond
    edited May 19, 2017 3:12AM

    Please remember that, as per the Terms of Use (https://www.oracle.com/legal/terms.html )

    4. Use of Community ServicesCommunity Services are provided as a convenience to users and Oracle is not obligated to provide any technical support for, or participate in, Community Services. While Community Services may include information regarding Oracle products and services, including information from Oracle employees, they are not an official customer support channel for Oracle.

    So you may not get a response from Oracle, not because they are not doing anything, but because they may not be monitoring these threads.  This is a public community.

This discussion has been closed.