Forum Stats

  • 3,780,675 Users
  • 2,254,423 Discussions


JRE 8u121 and 8u131 App-V Virtualization and JNLP issue

3480315 Member Posts: 4
edited Apr 17, 2018 5:40AM in Java Web Start & JNLP


We use App-V to distribute JRE to our XenDesktop users in Citrix enviroment.

Everything was working fine until we updated our app-v package from JRE 8u91 to 121. Applications that are using JNLP stopped working. They are not launching at all, Java splash screen appears for few seconds and after that... nothing. I have monitored processes. Under 8u91, 2 instances of javaws and one instance of jp2launcher is started. For 8u121 there is only one instance of javaws that gets closed after around 10 seconds without any output, no errors, nothing. I have tried to start few apps using javaws.exe -verbose app.jnlp and to enable tracing but no .trace files are created under u121 or u131.

  • It is working as expected when 8u121 is installed locally, only under app-v it's causing problems

  • It doesn't matter if i use x86 or x64 bit version of JRE
  • Interesting thing is, that with 8u131 and 8u121 I'm not even able to start
    javaws.exe -viewer (but i can do it using Java Control Panel GUI)
  • I prepared few app-v packages of different x86 an x64 JRE versions, all sequenced on the same machine following exactly same procedure. For 8u11 u45 and u91 that i have tested JNLP is working fine. For 8u121 and 131 we have that described behavior.
  • I have tried this also on different machines (win 7 and win 10)
  • I'm not specifying any particular applications that are affected because this can be reproduced using ANY application that is using JNLP to start 
  • As I mentioned, it was working fine with app-v sequences with JRE 8u91 and below, so something got changed in recent updates and it looks like app-v doesn't like it


This discussion has been closed.