Forum Stats

  • 3,769,008 Users
  • 2,252,898 Discussions
  • 7,874,840 Comments

Discussions

Oracle Forms 12 c, JAVA_HOME problem

adnanBIH
adnanBIH Member Posts: 151 Bronze Badge
edited Sep 5, 2017 10:25AM in Forms

Hello everyone.

I'm trying to install Oracle Forms&Reports 12c (fmw_12.2.1.3.0_fr_win64) on Windows 10, 64-bit machine, according next manual:

https://oracle-base.com/articles/12c/standalone-forms-builder-12c-installation-on-windows-1221

Everything goes fine until reaching point: Check the "Automatically Launch Forms Builder Configuration Wizard" option and click the "Finish" button. When I click on Next console window appear and show message:

error:
     JAVA_HOME environment variable is not set.  Set and rerun.

I also tried to manually run the Forms Configuration Wizard, but without success:

C:\Windows\system32>javac -versionjavac 1.8.0_144C:\Windows\system32>cd C:\Oracle\Oracle_FMW12c\forms\common\binC:\Oracle\Oracle_FMW12c\forms\common\bin>config_builder.cmdThe system cannot find the path specified.error:     JAVA_HOME environment variable is not set.  Set and rerun.

Environmental variables are in the next picture. Any ideas?

Regards, Adnan

Untitled.jpg

Tagged:

Best Answer

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 6,893 Employee
    edited Sep 5, 2017 9:47AM Accepted Answer

    When setting JAVA_HOME, if the path includes spaces, be sure to quote the value.

    JAVA_HOME="C:\Program Files\java\jdk1.8.0_144"

    Also note that having C:\ProgramData\Oracle\Java\javapath in your PATH can cause problems.  This entry is made by the installation of the JRE.  The problem with having it there is that typically it refers to the JRE which is most often a 32bit installation.  The result is that when a process that requires 64bit Java (java.exe), it incorrectly gets the 32bit version because of this PATH entry.

Answers

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 6,893 Employee
    edited Sep 5, 2017 9:47AM Accepted Answer

    When setting JAVA_HOME, if the path includes spaces, be sure to quote the value.

    JAVA_HOME="C:\Program Files\java\jdk1.8.0_144"

    Also note that having C:\ProgramData\Oracle\Java\javapath in your PATH can cause problems.  This entry is made by the installation of the JRE.  The problem with having it there is that typically it refers to the JRE which is most often a 32bit installation.  The result is that when a process that requires 64bit Java (java.exe), it incorrectly gets the 32bit version because of this PATH entry.

  • adnanBIH
    adnanBIH Member Posts: 151 Bronze Badge
    edited Sep 5, 2017 10:25AM

    Michael Ferrante-Oracle - thank you very much for lightspeed reply.

    I tried to set the JAVA_HOME with "" but failed. Then, I installed JDK in C:\Java\ folder, then set java_home to that location and it works!

    Regards, Adnan

    edit: where is Report builder, how to run it?

This discussion has been closed.